I upgraded from 18.04 to 20.04 and tried to enable dark mode but this is not working.

ubuntu dark mode enabled

Dark mode not working

Here is one more weird thing I noted. I am running Ubuntu 20.04 but this message shows 18.04. ubuntu 18.04 error on 20.04

Update: This command solved the problem. sudo apt-get install yaru-theme-gtk

  • Could you, please, check the Ubuntu version by typing: cat /etc/issue, and post the output.
    – Ollie
    May 11, 2020 at 20:43
  • Here is the output Ubuntu 20.04 LTS \n \l May 11, 2020 at 20:45
  • Then you are running on Ubuntu 20.04, I have no idea why the error message says that.
    – Ollie
    May 11, 2020 at 20:46
  • Is there a yaru-dark option?
    – Ollie
    May 11, 2020 at 20:47
  • 2
    Done. sudo apt-get install yaru-theme-gtk have done the task. Thanks :). May 11, 2020 at 20:56

3 Answers 3


As listed in comments from the question, I did install Yaru:

sudo apt-get install yaru-theme-gtk

Then I selected the dark theme from Settings > Appearance and it worked.

I obtained a similar yet different result by installing gnome-tweak-tool and selecting the "Ambiance" theme.


  • works like a charm.
    – R. Gurung
    Nov 18, 2020 at 16:33
  • After this it takes a long time to open files window. I am using Ubuntu 20 LTS
    – Aseem
    Jan 17, 2022 at 19:14
  • It works but now icon and directory invisible because there color is also black is there any solution to fix it. Feb 2, 2022 at 16:05

Try using the Gnome-Tweak tool. First, update, then add the Universe repository, and then install:

sudo apt-get update
sudo add-apt-repository universe
sudo apt-get install gnome-tweak-tool

Open Gnome-Tweaks from Show Applications (or Activities), and click on Appearance. Under Themes, dropdown Applications, and choose Adwaita-dark, or, as the case may be, Yaru-dark.

Hope it helps!

  • There is no option for Adwaita-dark. May 11, 2020 at 20:43
  • @Digvijaysingh Appearance --> Applications --> Adwaita-dark Oct 25, 2020 at 2:51
  • This works but answer by JLoDoesIT is correct.
    – R. Gurung
    Nov 18, 2020 at 16:33

I had this problem on Ubuntu 22.04. I found that the 'Accessibility' 'High Contrast' was turned on in 'Settings'. Turning this off let the Terminal window go to 'Dark' theme.

Hope this helps, TD

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.