Worked on my machine today, nothing special. Then out of the blue, the screen got frozen (not the first time), not responding any action (my music kept playing on the background), so I shut down the computer (force shut down, long pressing the power button) and tried to reload, grub was loaded normally, but when it was time to fire up Ubuntu it got stuck on my PC logo (tuf gaming). Tried again to open Ubuntu this time with nomodeset flag but no luck. Then removed the quiet splash trying to spot anything abnormal, it got stuck on the line (uninitialized): registered PHC clock. Also tried the recovery mode and got the same result (tried it a few times later always stops around this line something one more or one less)

The computer has a dual boot with window 10 as well [i5-9400F, 16Gb RAM, 2TB Hd, GeForce GT 710]

I opened Windows, download Ubuntu 18.04 desktop version from the official website, used Rufus to make a live USB, and gave it a try. I got into grub again and choose the Try Ubuntu option and once again it got stuck on my PC logo, also tried Ubuntu 16.04, and got the same results.

I don't know what else to try.

I appreciate any kind of help. Thanks.


I had this problem during my installation in my workstation. The problem then turned out to be a bad harddrive. Check if the harddrive is fine. A dying harddrive typically gives this problem.

  • The PC is working fine with Windows. How would you advice to check the hard drive? – MaZ May 11 '20 at 20:37
  • My computer had a working windows as dual boot working fine. The possible explanation is that part of hardrive gets malfunctioned. – Praveen Kumar-M May 11 '20 at 20:40
  • I checked the hardrive using the Perform a Hard Drive Self Test from the BIOS – Praveen Kumar-M May 11 '20 at 20:41

So I had couple of intense days at work and didn't have the time to fix my machine, today when I tried to boot up I got into new screen ''' /dev/sdb5 Found invalid V2 journal superblock fields (from V2 journal). Clearing fields beyond the V1 journal superblock...

/dev/sdb5: One or more block group descriptor checksums are invalid. FIXED. /dev/sdb5: Group descriptor 0 checksum is 0x...., Should be 0x.... .

/dev/sdb5 UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. fsck exited with status code 4 The root filesystem on /dev/sdb5 requires a manual fsck '''

And I got a "BusyBox" shell, I ran '''fsck -yf /dev/sdb5 ''' It worked for a minute or so and was saying "FIXED" here and there. Then I ran '''exit''' and let the system reboot. Now I got back to the normal login screen!

TBH I'm not quite sure what action I took that lead me into this screen.

Then I faced a more common problem, I got into login loop. Tried taking owner ship over .Xauthority, switch to lightdm both didn't worked. then tried '''sudo startx''' and was able to get the full gui, created new user and was able to login with him.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.