7

While installing the Ubuntu 20.04 updates during upgrade from 19.10 to 20.04, my screen suddenly went completely white and displayed a message saying

Please logout and try again.

But I could not locate my cursor and so I switched off my laptop. After restarting it again, it was showing an error message saying

Please update the microcode

Why did this happen? How can I solve this problem?

4
  • 1
    The easiest way is to do a fresh install.
    – Pilot6
    May 11, 2020 at 19:28
  • but that might result in loss of data, right?
    – Ak26
    May 11, 2020 at 19:33
  • 3
    Yes, if you do all wrong. You should have had a backup already before starting the upgrade.
    – Pilot6
    May 11, 2020 at 19:36
  • Does this answer your question? Intel Microcode Necessary?
    – karel
    May 12, 2020 at 10:15

1 Answer 1

12

You still can try to fix this interrupted upgrade from a live USB/CD.

To fix from a live USB/CD, boot into the live system then connect to Internet from the live system and open a terminal then follow these steps:

Run:

sudo fdisk -l

And identify your root partition. It could be something like /dev/sda1 then mount it to /mnt like so:

sudo mount /dev/sda1 /mnt/

Then run:

sudo mount --bind /proc/ /mnt/proc/

Then run:

sudo mount --bind /sys/ /mnt/sys/

Then run:

sudo mount --bind /dev/ /mnt/dev/

Then run:

sudo cp /etc/resolv.conf /mnt/etc/resolv.conf

Then run:

sudo chroot /mnt/

Now you are in your original system on the hard disk. Run first:

dpkg --configure -a

Then, update APT like so:

apt update

Then, install upgrades like so:

apt upgrade

When finished run:

exit

Then run:

sudo umount /mnt/dev/

Then run:

sudo umount /mnt/sys/

Then run:

sudo umount /mnt/proc/

Then run:

sudo umount /mnt/

Then reboot to your original system, it should be fixed

5
  • 1
    I'd just like to say that this worked for me. I couldn't unmount /mnt/sys so had to google that part a bit, i ended up using unmount -l /mnt/sys
    – Nikola
    Oct 31, 2020 at 21:41
  • 1
    This worked for me! I use a DigitalOcean droplet and tried upgrading from the previous LTS to 20.04 and I ended up with a kernal panic. I rebooted into the recovery mode, launched the terminal and ran your commands. Unmounting /mnt/sys/ and /mnt/ was unnecessary for me, thankfully. The DO console is very buggy and is largely to blame (I couldn't see what the upgrade was asking of me in the console because everything is cut off and scrolling isn't possible). Dec 30, 2020 at 18:15
  • 1
    This is very helpful! What is the resolve.conf step for? Aug 11, 2023 at 11:17
  • @OrganicMarble This will copy your currently configured search domains from the live system to the chroot environment so that applications that rely on it to resolve DNS will work e.g. resolving repositories URIs from /etc/apt/sources.list when you do e.g. apt update from the terminal ... That change, however, will not persist after booting from the system on disk as it is symlinked to /run/systemd/resolve/stub-resolv.conf which is dynamically managed by systemd-resolved.
    – Raffa
    Aug 11, 2023 at 11:39
  • Thanks very much for the detailed explanation. Aug 11, 2023 at 11:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .