2

I am trying to set up a greenscreen effect for a video conference in Google Meet, which runs in a web browser, in this case Google Chrome. As an initial test I have set up a V4L2 loopback device and am feeding it a video as outlined in this answer. However, when I go to select the device, I only see the build-in webcam, with no option for the second video source I have added which is showing up as /dev/video2. I also went to chrome://settings/content/camera and it is not showing my new video source. I also tried restarting Chrome, but it still does not show up.

I am able to run ffplay on /dev/video2 and it shows my video, so I know that part is working!

How do I get Google Chrome to recognize my second video source?

(Running Ubuntu 18.04 LTS)

8
  • To start with, which version of Linux have you installed (Ubuntu server, Ubuntu desktop, Kubuntu, Lubuntu, Xubuntu, Ubuntu MATE, et al.) , and which release number? Different releases have different tools for us to recommend. Please click edit and add that vital information to your question so all the facts we need are in the question. Please don't use Add Comment, since that's our channel to you. All facts about your system should go in the Question with edit – K7AAY May 11 '20 at 19:25
  • @Raffa No. I have the video source set up, this question is about getting it to be recognized by Google Chrome so I can use it in something like Google Meet, which is supposed to detect available video sources directly from the web page. – Michael May 11 '20 at 22:56
  • 1
    Actually I meant to use exclusive_caps and give a name to the virtual camera like so sudo modprobe v4l2loopback exclusive_caps=1 card_label="MyLaptopCam:MyLaptopCam" and to try the note on "To use it with Google Hangouts" at the end of the accepted answer. exclusive_caps is meant to enable google chrome to see the virtual camera. – Raffa May 11 '20 at 23:14
  • @Raffa Ah. No, I tried that. The only thing I noticed with that is that I had to start sending video to the device before anything would recognize it (such as Meet in Firefox). I didn't see the label part though, I will try that. – Michael May 11 '20 at 23:17
  • 1
    @Raffa Well I tried with the additional card_label parameter and it did work. – Michael May 11 '20 at 23:58