0

I have a problem that is very hard for me to diagnose in the first place. I am locked out from my computer which is in my workplace and due to the outbreak I am not allowed to go to my work to get access to it. So I have limited information about the box at the moment and I can get a person from IT to help me with this. Currently the situation is the following:

I have the hard-drive encrypted with LUKS. I observed that I had trouble with my machine and the graphics while I was remotely connected to it. So knowing that my computer is encrypted and restarting would have let me out, I tried to disabled the LUKS encryption. I figured out that is not possible to disable easily the LUKS encryption, but I found this tutorial which describes a way to automatically make the LUKS system to read the password from a file and enter it automatically. My intuition was if I do this then restarting the computer should bypass automatically the LUKS encryption screen.

Today, I got more information about the case from someone who is there. They said that the computer displays "cryptsetup going to sleep for 60 seconds" and nothing is happening. Getting to advanced settings in GRUB to enter the root is not possible either.

I suspect that the trick I did to automatically bypass the LUKS system do something and enters the password incorrectly which forces LUKS to lock me down. Restarting will get me to this stage all the time and I don't have the option to enter the password myself anymore.

The important thing is that I have a password on my hard disk and then I edited /etc/crypttab and updated the line below to look the password from the file instead:

sda5_crypt UUID=9b7200b5-0e0a-447a-93a8-7eb8f1f4a1ee /dev/disk/by-uuid/<uuid>:/keyfile luks,keyscript=/lib/cryptsetup/scripts/passdev

Is there any way I can force the computer to allow me to enter the encryption password? We tried to enter the advanced menu in GRUB to get root access but this is not possible either. I think at this point we get into initramfs or something like this.

I am afraid that's the information I have at the moment and I can't obtain more info to enhance this question. I am hoping there is a keystroke we can type to tell LUKS to allow us to enter the password.

System information

  • Ubuntu Desktop 18.04
5
  • Is what you quote as the crypttab file exactly what is running on the system? The "/dev/disk/by-uuid/<uuid>:" part should not be there, that's a template. Also, why are you using the keyscript option? The keyfile can be specified directly as the third entry in the line. Alternatively, put the password directly into crypttab if that's acceptable.
    – Sebastian
    Commented May 11, 2020 at 17:29
  • Hello, thanks for your time. No, that's an example. What's on the system is different and I cannot recall exactly its content. But the structure is similar. The thing is that I don't have access to my computer anymore. Can I still edit that file you mean?
    – Phrixus
    Commented May 11, 2020 at 17:39
  • To start with, which version of Linux have you installed (Ubuntu server, Ubuntu desktop, Kubuntu, Lubuntu, Xubuntu, Ubuntu MATE, et al.) , and which release number? Different releases have different tools for us to recommend. Please click edit and add that vital information to your question so all the facts we need are in the question. Please don't use Add Comment, since that's our channel to you. All facts about your system should go in the Question with edit
    – K7AAY
    Commented May 11, 2020 at 17:45
  • 1
    You will have to verify the contents of crypttab and potentially correct it. That tutorial you cited is not unambiguous and seems to make some assumptions on the device structure etc., so if you copied it 1:1 it's possible you bricked your system.
    – Sebastian
    Commented May 11, 2020 at 17:48
  • Hi thanks for your help. I just updated my question.
    – Phrixus
    Commented May 11, 2020 at 18:20

0

You must log in to answer this question.

Browse other questions tagged .