0

When I download a file, if I try to open it or it's containing folder all I get is the Launch Application dialog asking me to choose an application. No applications are listed for me to choose from and if I select 'Choose other Application' it only lets me choose my own applications, not system ones (e.g. nautilus). This is a change from 18.04 which worked as expected. I assume its some kind of security/privilege issue but have no idea what to do about it. This is the snap version of firefox:

rod@Isildur:~$ apt policy firefox
firefox:
  Installed: 76.0+build2-0ubuntu0.20.04.1
  Candidate: 76.0+build2-0ubuntu0.20.04.1
  Version table:
 *** 76.0+build2-0ubuntu0.20.04.1 500
        500 http://gb.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages
        100 /var/lib/dpkg/status
     75.0+build3-0ubuntu1 500
        500 http://gb.archive.ubuntu.com/ubuntu focal/main amd64 Packages
rod@Isildur:~$ snap list | grep -i firefox
firefox             76.0-2                      355   latest/stable  mozilla*      -

Checked it out today with 76.0.1 and its still the same. I've removed the snap and it now works properly.

If anyone else wants to remove the snap I suggest snap remove --purge firefox to avoid making a huge snapshot.

Beware though, this will lose your open tabs, bookmarks, history. The snap seems a bit of a mess really.

  • 3
    Is this Firefox a snap application? Please edit your question with the outputs of the following two commands in Terminal: apt policy firefox and snap list | grep -i firefox – pomsky May 11 at 15:11
  • 1
    That seems to be a problem with the snap version only. As a workaround I'd suggest you use the DEB version. You can uninstall the snap version with snap remove firefox. – Béné May 11 at 16:01
  • Do you know if it has been reported as a bug? – rodders May 12 at 13:20
0

If stable firefox version does not work as expected and you need a snap version, you could try a different installation channel:

sudo snap install firefox --beta

enter image description here

| improve this answer | |
0

You have installed both the deb package of Firefox, and the snap package of Firefox. When you launch Firefox, you end up running the snap package that has some security features relating to file associations. Those are being resolved, and probably it is not ready yet.

Therefore, uninstall Firefox from the Snap Store, and you will be able to launch the deb package of Firefox that does not have these issues.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.