6

I have upgraded from Ubuntu 19.10 to 20.04, and now I have a problem with my graphics rendering (strange squares on background and font problems). I use the i915 driver. Graphics card: Skylake GT2 HD Graphics 520. I tried to reinstall GNOME shell and Xorg server. Nothing helped. Also Chrome browser breaks on most of pages.

screenshot

  • Given the output, do you have a way to try with another graphics adapter on this same machine? I am wondering, because Chrome uses all kinds of GPU acceleration. And so issues with the graphics card (or the respective driver) would be expected to cause the issues you describe. – 0xC0000022L May 11 at 10:36
  • unfortunately I can’t use another video card, this is a laptop. – Veniamin May 11 at 12:07
  • @Veniamin I feared as much. You may want to also look at answers to this other answer where the OP seems to experience surprisingly similar symptoms. – 0xC0000022L May 11 at 12:21
  • I look at upgrade log and find out: file /etc/X11/xorg.conf was missing. Probably I deleted it earlier. I restore this file with sudo X -configure and copy new file to /etc/X11/xorg.conf. But problem exists – Veniamin May 11 at 12:27
  • I tried to install latest video drivers from ppa:oibaf/graphics-drivers and install kernel 5.4.0-28 intead of 5.4.0-29. It did not help. – Veniamin May 11 at 13:01
7

I had the similar problem and on my research found that it's intel new graphic update problem. I was able to solve my issue by issuing following commands on my terminal.

sudo apt purge xserver-xorg-video-intel

After issuing the command, it is recommended that you restart your pc but logout and log back in may also work fine. I hope this will be able to solve your problem. If you face any issue please let me know.

| improve this answer | |
  • 1
    Thank you! It had solved my problem! Chrome also stopped crashing. – Veniamin May 12 at 8:30
  • 1
    You are always welcome! – proamar May 12 at 14:24
  • Thanks this worked for me too! Only needed to logout and back in, no restart needed. – zzbomb May 21 at 4:39
  • This answer solve the issue by uninstalling the 'xserver-xorg-video-intel' driver, which is in fact recommanded when using Intel graphic cards newer than 2007: packages.debian.org/en/sid/xserver-xorg-video-intel Seems you can safely uninstall this driver if your hardware is new enough. – Togh May 21 at 11:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.