2

When I run sudo apt install python 3.8 on my Ubuntu 18.04.4 LTS, it has installed haskell packages (libghs) together with python and libghs eats more 2 GB disk space. It's seems that module regex '3.8' needs in libghs.

Is it bug of ubuntu package manager? Can I safe uninstall haskell packages?

First 300 lines of installation log:

victor@ironUbuntu:~/programs/converters$ sudo apt install python 3.8
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'python3.8-venv' for regex '3.8'
Note, selecting 'libghc-yi-mode-javascript-dev-0.14.1-3f8dc' for regex '3.8'
Note, selecting 'libghc-blogliterately-dev-0.8.4.3-804c2' for regex '3.8'
Note, selecting 'libghc-base-compat-prof-0.9.3-8575a' for regex '3.8'
Note, selecting 'libghc-extra-prof-1.5.3-801ec' for regex '3.8'
Note, selecting 'libpython3.8-dbg' for regex '3.8'
Note, selecting 'libpython3.8-dev' for regex '3.8'
Note, selecting 'python3-m3u8' for regex '3.8'
Note, selecting 'libghc-nettle-prof-0.2.0-e3485' for regex '3.8'
Note, selecting 'libghc-file-embed-dev-0.0.10-3484f' for regex '3.8'
Note, selecting 'libpython3.8-minimal' for regex '3.8'
Note, selecting 'clang-3.8' for regex '3.8'
Note, selecting 'libghc-curl-prof-1.3.8-45ab8' for regex '3.8'
Note, selecting 'libghc-utf8-light-dev-0.4.2-358ce' for regex '3.8'
Note, selecting 'libghc-word8-prof-0.1.3-85f4f' for regex '3.8'
Note, selecting 'python-clang-3.8' for regex '3.8'
Note, selecting 'python-rfc3986' for regex '3.8'
Note, selecting 'libghc-hsx-jmacro-dev-7.3.8-ab142' for regex '3.8'
Note, selecting 'libghc-yi-mode-javascript-prof-0.14.1-3f8dc' for regex '3.8'
Note, selecting 'libghc-curl-dev-1.3.8-45ab8' for regex '3.8'
Note, selecting 'libid3-3.8.3-dev' for regex '3.8'
Note, selecting 'libghc-word8-dev-0.1.3-85f4f' for regex '3.8'
Note, selecting 'python3.8-examples' for regex '3.8'
Note, selecting 'libpython3.8' for regex '3.8'
Note, selecting 'python3.8-gdbm' for regex '3.8'
Note, selecting 'python3.8' for regex '3.8'
Note, selecting 'libghc-boundedchan-dev-1.0.3.0-73f82' for regex '3.8'
Note, selecting 'libghc-yesod-persistent-dev-1.4.3-63780' for regex '3.8'
Note, selecting 'libghc-text-binary-dev-0.2.1.1-03183' for regex '3.8'
Note, selecting 'libghc-nettle-dev-0.2.0-e3485' for regex '3.8'
Note, selecting 'asterisk-1fb7f5c06d7a2052e38d021b3d8ca151' for regex '3.8'
Note, selecting 'libghc-base-compat-dev-0.9.3-8575a' for regex '3.8'
Note, selecting 'libghc-utf8-light-prof-0.4.2-358ce' for regex '3.8'
Note, selecting 'python3.8-lib2to3' for regex '3.8'
Note, selecting 'libghc-hsx-jmacro-prof-7.3.8-ab142' for regex '3.8'
Note, selecting 'libghc-file-embed-prof-0.0.10-3484f' for regex '3.8'
Note, selecting 'python3.8-distutils' for regex '3.8'
Note, selecting 'libghc-unix-time-dev-0.3.7-5348a' for regex '3.8'
Note, selecting 'pr3287' for regex '3.8'
Note, selecting 'libmm-ocaml-b3880' for regex '3.8'
Note, selecting 'libid3-3.8.3' for regex '3.8'
Note, selecting 'python3.8-minimal' for regex '3.8'
Note, selecting 'idle-python3.8' for regex '3.8'
Note, selecting 'libmm-ocaml-dev-b3880' for regex '3.8'
Note, selecting 'libntfs-3g88' for regex '3.8'
Note, selecting 'libghc-test-framework-th-prime-prof-0.0.10-338d6' for regex '3.8'
Note, selecting 'python-m3u8' for regex '3.8'
Note, selecting 'nvidia-358-updates' for regex '3.8'
Note, selecting 'libghc-unix-time-prof-0.3.7-5348a' for regex '3.8'
Note, selecting 'nvidia-378-updates' for regex '3.8'
Note, selecting 'libghc-text-binary-prof-0.2.1.1-03183' for regex '3.8'
Note, selecting 'python3.8-tk' for regex '3.8'
Note, selecting 'libghc-boundedchan-prof-1.0.3.0-73f82' for regex '3.8'
Note, selecting 'libghc-test-framework-th-prime-dev-0.0.10-338d6' for regex '3.8'
Note, selecting 'libpython3.8-stdlib' for regex '3.8'
Note, selecting 'python3-rfc3986' for regex '3.8'
Note, selecting 'python3.8-dbg' for regex '3.8'
Note, selecting 'python3.8-dev' for regex '3.8'
Note, selecting 'python3.8-doc' for regex '3.8'
Note, selecting 'cl-rfc2388' for regex '3.8'
Note, selecting 'libghc-entropy-prof-0.3.8-e716f' for regex '3.8'
Note, selecting 'libghc-blogliterately-prof-0.8.4.3-804c2' for regex '3.8'
Note, selecting 'libghc-extra-dev-1.5.3-801ec' for regex '3.8'
Note, selecting 'libghc-entropy-dev-0.3.8-e716f' for regex '3.8'
Note, selecting 'python-lldb-3.8' for regex '3.8'
Note, selecting 'vdr-abi-2.3.8-debian' for regex '3.8'
Note, selecting 'nvidia-experimental-358' for regex '3.8'
Note, selecting 'nvidia-experimental-378' for regex '3.8'
Note, selecting 'libpython3.8-testsuite' for regex '3.8'
Note, selecting 'libghc-yesod-persistent-prof-1.4.3-63780' for regex '3.8'
Note, selecting 'libid3-3.8.3c2a' for regex '3.8'
Note, selecting 'nvidia-358' for regex '3.8'
Note, selecting 'nvidia-378' for regex '3.8'
Note, selecting 'libid3-3.8.3c2' for regex '3.8'
Note, selecting 'libid3-3.8.3v5' for regex '3.8'
Note, selecting 'asterisk' instead of 'asterisk-1fb7f5c06d7a2052e38d021b3d8ca151'
Note, selecting 'libghc-base-compat-dev' instead of 'libghc-base-compat-dev-0.9.3-8575a'
Note, selecting 'libghc-base-compat-prof' instead of 'libghc-base-compat-prof-0.9.3-8575a'
Note, selecting 'libghc-text-binary-dev' instead of 'libghc-text-binary-dev-0.2.1.1-03183'
Note, selecting 'libghc-text-binary-prof' instead of 'libghc-text-binary-prof-0.2.1.1-03183'
Note, selecting 'libghc-blogliterately-dev' instead of 'libghc-blogliterately-dev-0.8.4.3-804c2'
Note, selecting 'libghc-blogliterately-prof' instead of 'libghc-blogliterately-prof-0.8.4.3-804c2'
Note, selecting 'libghc-boundedchan-dev' instead of 'libghc-boundedchan-dev-1.0.3.0-73f82'
Note, selecting 'libghc-boundedchan-prof' instead of 'libghc-boundedchan-prof-1.0.3.0-73f82'
Note, selecting 'libghc-entropy-dev' instead of 'libghc-entropy-dev-0.3.8-e716f'
Note, selecting 'libghc-entropy-prof' instead of 'libghc-entropy-prof-0.3.8-e716f'
Note, selecting 'libghc-curl-dev' instead of 'libghc-curl-dev-1.3.8-45ab8'
Note, selecting 'libghc-curl-prof' instead of 'libghc-curl-prof-1.3.8-45ab8'
Note, selecting 'libghc-extra-dev' instead of 'libghc-extra-dev-1.5.3-801ec'
Note, selecting 'libghc-extra-prof' instead of 'libghc-extra-prof-1.5.3-801ec'
Note, selecting 'libghc-unix-time-dev' instead of 'libghc-unix-time-dev-0.3.7-5348a'
Note, selecting 'libghc-unix-time-prof' instead of 'libghc-unix-time-prof-0.3.7-5348a'
Note, selecting 'libghc-file-embed-dev' instead of 'libghc-file-embed-dev-0.0.10-3484f'
Note, selecting 'libghc-file-embed-prof' instead of 'libghc-file-embed-prof-0.0.10-3484f'
Note, selecting 'libghc-hsx-jmacro-dev' instead of 'libghc-hsx-jmacro-dev-7.3.8-ab142'
Note, selecting 'libghc-hsx-jmacro-prof' instead of 'libghc-hsx-jmacro-prof-7.3.8-ab142'
Note, selecting 'libghc-nettle-dev' instead of 'libghc-nettle-dev-0.2.0-e3485'
Note, selecting 'libghc-nettle-prof' instead of 'libghc-nettle-prof-0.2.0-e3485'
Note, selecting 'libghc-word8-dev' instead of 'libghc-word8-dev-0.1.3-85f4f'
Note, selecting 'libghc-word8-prof' instead of 'libghc-word8-prof-0.1.3-85f4f'
Note, selecting 'libghc-test-framework-th-prime-dev' instead of 'libghc-test-framework-th-prime-dev-0.0.10-338d6'
Note, selecting 'libghc-test-framework-th-prime-prof' instead of 'libghc-test-framework-th-prime-prof-0.0.10-338d6'
Note, selecting 'libghc-utf8-light-dev' instead of 'libghc-utf8-light-dev-0.4.2-358ce'
Note, selecting 'libghc-utf8-light-prof' instead of 'libghc-utf8-light-prof-0.4.2-358ce'
Note, selecting 'libghc-yesod-persistent-dev' instead of 'libghc-yesod-persistent-dev-1.4.3-63780'
Note, selecting 'libghc-yesod-persistent-prof' instead of 'libghc-yesod-persistent-prof-1.4.3-63780'
Note, selecting 'libghc-yi-mode-javascript-dev' instead of 'libghc-yi-mode-javascript-dev-0.14.1-3f8dc'
Note, selecting 'libghc-yi-mode-javascript-prof' instead of 'libghc-yi-mode-javascript-prof-0.14.1-3f8dc'
Note, selecting 'libmm-ocaml' instead of 'libmm-ocaml-b3880'
Note, selecting 'libmm-ocaml-dev' instead of 'libmm-ocaml-dev-b3880'
Note, selecting 'vdr' instead of 'vdr-abi-2.3.8-debian'
Note, selecting 'python3-distutils' instead of 'python3.8-distutils'
Note, selecting 'python3-gdbm' instead of 'python3.8-gdbm'
Note, selecting 'python3-lib2to3' instead of 'python3.8-lib2to3'
Note, selecting 'python3-tk' instead of 'python3.8-tk'
python is already the newest version (2.7.15~rc1-1).
libntfs-3g88 is already the newest version (1:2017.3.23-2ubuntu0.18.04.2).
python3-distutils is already the newest version (3.6.9-1~18.04).
python3-distutils set to manually installed.
python3-gdbm is already the newest version (3.6.9-1~18.04).
python3-lib2to3 is already the newest version (3.6.9-1~18.04).
python3-lib2to3 set to manually installed.
The following additional packages will be installed:
  3270-common asterisk-config asterisk-core-sounds-en
  asterisk-core-sounds-en-gsm asterisk-modules asterisk-moh-opsound-gsm
  asterisk-voicemail autotools-dev blt camlp4 fonts-mathjax freetds-common ghc
  ghc-prof gir1.2-harfbuzz-0.0 icu-devtools ledit libbibutils-dev libbibutils2
  libbsd-dev libcamlp4-ocaml-dev libcurl4-openssl-dev libffi-dev
  libfindlib-ocaml libfindlib-ocaml-dev libftdi1-2 libghc-adjunctions-dev
  libghc-adjunctions-prof libghc-aeson-compat-dev libghc-aeson-compat-prof
  libghc-aeson-dev libghc-aeson-prof libghc-ansi-terminal-dev
  libghc-ansi-terminal-prof libghc-ansi-wl-pprint-dev
  libghc-ansi-wl-pprint-prof libghc-appar-dev libghc-appar-prof
  libghc-asn1-encoding-dev libghc-asn1-encoding-prof libghc-asn1-parse-dev
  libghc-asn1-parse-prof libghc-asn1-types-dev libghc-asn1-types-prof
  libghc-async-dev libghc-async-prof libghc-attoparsec-dev
  libghc-attoparsec-iso8601-dev libghc-attoparsec-iso8601-prof
  libghc-attoparsec-prof libghc-auto-update-dev libghc-auto-update-prof
  libghc-base-orphans-dev libghc-base-orphans-prof
  libghc-base64-bytestring-dev libghc-base64-bytestring-prof
  libghc-basement-dev libghc-basement-prof libghc-bifunctors-dev
  libghc-bifunctors-prof libghc-blaze-builder-dev libghc-blaze-builder-prof
  libghc-blaze-html-dev libghc-blaze-html-prof libghc-blaze-markup-dev
  libghc-blaze-markup-prof libghc-bool-extras-dev libghc-bool-extras-prof
  libghc-byteable-dev libghc-byteable-prof libghc-byteorder-dev
  libghc-byteorder-prof libghc-call-stack-dev libghc-call-stack-prof
  libghc-case-insensitive-dev libghc-case-insensitive-prof libghc-cereal-dev
  libghc-cereal-prof libghc-charsetdetect-ae-dev libghc-charsetdetect-ae-prof
  libghc-cipher-aes-dev libghc-cipher-aes-prof libghc-clientsession-dev
  libghc-clientsession-prof libghc-clock-dev libghc-clock-prof
  libghc-cmark-dev libghc-cmark-prof libghc-cmdargs-dev libghc-cmdargs-prof
  libghc-comonad-dev libghc-comonad-prof libghc-conduit-dev
  libghc-conduit-extra-dev libghc-conduit-extra-prof libghc-conduit-prof
  libghc-connection-dev libghc-connection-prof libghc-contravariant-dev
  libghc-contravariant-prof libghc-cookie-dev libghc-cookie-prof
  libghc-cpphs-dev libghc-cpphs-prof libghc-cprng-aes-dev
  libghc-cprng-aes-prof libghc-crypto-api-dev libghc-crypto-api-prof
  libghc-crypto-cipher-types-dev libghc-crypto-cipher-types-prof
  libghc-crypto-random-dev libghc-crypto-random-prof libghc-cryptonite-dev
  libghc-cryptonite-prof libghc-data-default-class-dev
  libghc-data-default-class-prof libghc-data-default-dev
  libghc-data-default-instances-containers-dev
  libghc-data-default-instances-containers-prof
  libghc-data-default-instances-dlist-dev
  libghc-data-default-instances-dlist-prof
  libghc-data-default-instances-old-locale-dev
  libghc-data-default-instances-old-locale-prof libghc-data-default-prof
  libghc-deepseq-generics-dev libghc-deepseq-generics-prof libghc-digest-dev
  libghc-digest-prof libghc-distributive-dev libghc-distributive-prof
  libghc-dlist-dev libghc-dlist-prof libghc-doctemplates-dev
  libghc-doctemplates-prof libghc-dynamic-state-dev libghc-dynamic-state-prof
  libghc-easy-file-dev libghc-easy-file-prof libghc-exceptions-dev
  libghc-exceptions-prof libghc-extensible-exceptions-dev
  libghc-extensible-exceptions-prof libghc-fast-logger-dev
  libghc-fast-logger-prof libghc-filemanip-dev libghc-filemanip-prof
  libghc-fingertree-dev libghc-fingertree-prof libghc-fmlist-dev
  libghc-fmlist-prof libghc-foundation-dev libghc-foundation-prof
  libghc-free-dev libghc-free-prof libghc-generic-deriving-dev
  libghc-generic-deriving-prof libghc-haddock-library-dev
  libghc-haddock-library-prof libghc-hashable-dev libghc-hashable-prof
  libghc-haxml-dev libghc-haxml-prof libghc-haxr-dev libghc-haxr-prof
  libghc-highlighting-kate-dev libghc-highlighting-kate-prof
  libghc-hostname-dev libghc-hostname-prof libghc-hourglass-dev
  libghc-hourglass-prof libghc-hs-bibutils-dev libghc-hs-bibutils-prof
  libghc-hscolour-dev libghc-hscolour-prof libghc-hslua-dev libghc-hslua-prof
  libghc-hsopenssl-dev libghc-hsopenssl-prof libghc-hsp-dev libghc-hsp-prof
  libghc-http-api-data-dev libghc-http-api-data-prof libghc-http-client-dev
  libghc-http-client-prof libghc-http-client-tls-dev
  libghc-http-client-tls-prof libghc-http-common-dev libghc-http-common-prof
  libghc-http-date-dev libghc-http-date-prof libghc-http-dev libghc-http-prof
  libghc-http-streams-dev libghc-http-streams-prof libghc-http-types-dev
  libghc-http-types-prof libghc-http2-dev libghc-http2-prof
  libghc-hxt-charproperties-dev libghc-hxt-charproperties-prof libghc-hxt-dev
  libghc-hxt-prof libghc-hxt-regex-xmlschema-dev
  libghc-hxt-regex-xmlschema-prof libghc-hxt-unicode-dev
  libghc-hxt-unicode-prof libghc-integer-logarithms-dev
  libghc-integer-logarithms-prof libghc-io-streams-dev libghc-io-streams-prof
  libghc-iproute-dev libghc-iproute-prof libghc-jmacro-dev libghc-jmacro-prof
  libghc-juicypixels-dev libghc-juicypixels-prof libghc-kan-extensions-dev
  libghc-kan-extensions-prof libghc-lens-dev libghc-lens-prof
  libghc-lifted-base-dev libghc-lifted-base-prof libghc-listlike-dev
  libghc-listlike-prof libghc-math-functions-dev libghc-math-functions-prof
  libghc-memory-dev libghc-memory-prof libghc-microlens-dev
  libghc-microlens-ghc-dev libghc-microlens-ghc-prof libghc-microlens-mtl-dev
  libghc-microlens-mtl-prof libghc-microlens-platform-dev
  libghc-microlens-platform-prof libghc-microlens-prof libghc-microlens-th-dev
  libghc-microlens-th-prof libghc-mime-types-dev libghc-mime-types-prof
  libghc-mmorph-dev libghc-mmorph-prof libghc-monad-control-dev
  libghc-monad-control-prof libghc-monad-logger-dev libghc-monad-logger-prof
  libghc-monad-loops-dev libghc-monad-loops-prof libghc-mtl-dev
  libghc-mtl-prof libghc-mwc-random-dev libghc-mwc-random-prof
  libghc-network-dev libghc-network-prof libghc-network-uri-dev
  libghc-network-uri-prof libghc-old-locale-dev libghc-old-locale-prof
  libghc-old-time-dev libghc-old-time-prof libghc-oo-prototypes-dev
  libghc-oo-prototypes-prof libghc-openssl-streams-dev
  libghc-openssl-streams-prof libghc-pandoc-citeproc-data
  libghc-pandoc-citeproc-dev libghc-pandoc-citeproc-prof libghc-pandoc-dev
  libghc-pandoc-prof libghc-pandoc-types-dev libghc-pandoc-types-prof
  libghc-parallel-dev libghc-parallel-prof libghc-parseargs-dev
  libghc-parsec3-dev libghc-parsec3-prof libghc-path-pieces-dev
  libghc-path-pieces-prof libghc-pcre-light-dev libghc-pcre-light-prof
  libghc-pem-dev libghc-pem-prof libghc-persistent-dev libghc-persistent-prof
  libghc-persistent-template-dev libghc-persistent-template-prof
  libghc-pointedlist-dev libghc-pointedlist-prof libghc-polyparse-dev
  libghc-polyparse-prof libghc-prelude-extras-dev libghc-prelude-extras-prof
  libghc-primitive-dev libghc-primitive-prof libghc-process-extras-dev
  libghc-process-extras-prof libghc-profunctors-dev libghc-profunctors-prof
  libghc-psqueues-dev libghc-psqueues-prof libghc-quickcheck2-dev
  libghc-quickcheck2-prof libghc-random-dev libghc-random-prof
  libghc-reflection-dev libghc-reflection-prof libghc-regex-base-dev
  libghc-regex-base-prof libghc-regex-pcre-dev libghc-regex-pcre-prof
  libghc-regex-posix-dev libghc-regex-posix-prof libghc-regex-tdfa-dev
  libghc-regex-tdfa-prof libghc-resource-pool-dev libghc-resource-pool-prof
  libghc-resourcet-dev libghc-resourcet-prof libghc-safe-dev libghc-safe-prof
  libghc-scientific-dev libghc-scientific-prof libghc-securemem-dev
  libghc-securemem-prof libghc-semigroupoids-dev libghc-semigroupoids-prof
  libghc-semigroups-dev libghc-semigroups-prof libghc-setenv-dev
  libghc-setenv-prof libghc-sha-dev libghc-sha-prof libghc-shakespeare-dev
  libghc-shakespeare-prof libghc-silently-dev libghc-silently-prof
  libghc-simple-sendfile-dev libghc-simple-sendfile-prof libghc-skein-dev
  libghc-skein-prof libghc-skylighting-dev libghc-skylighting-prof
  libghc-socks-dev libghc-socks-prof libghc-split-dev libghc-split-prof
  libghc-src-exts-dev libghc-src-exts-prof libghc-src-meta-dev
  libghc-src-meta-prof libghc-statevar-dev libghc-statevar-prof
  libghc-stm-chans-dev libghc-stm-chans-prof libghc-stm-dev libghc-stm-prof
  libghc-streaming-commons-dev libghc-streaming-commons-prof libghc-strict-dev
  libghc-strict-prof libghc-stringsearch-dev libghc-stringsearch-prof
  libghc-syb-dev libghc-syb-prof libghc-tagged-dev libghc-tagged-prof
  libghc-tagsoup-dev libghc-tagsoup-prof libghc-temporary-dev
  libghc-temporary-prof libghc-test-framework-dev libghc-test-framework-prof
  libghc-texmath-dev libghc-texmath-prof libghc-text-dev libghc-text-icu-dev
  libghc-text-icu-prof libghc-text-prof libghc-tf-random-dev
  libghc-tf-random-prof libghc-th-abstraction-dev libghc-th-abstraction-prof
  libghc-th-expand-syns-dev libghc-th-expand-syns-prof libghc-th-lift-dev
  libghc-th-lift-instances-dev libghc-th-lift-instances-prof
  libghc-th-lift-prof libghc-th-orphans-dev libghc-th-orphans-prof
  libghc-th-reify-many-dev libghc-th-reify-many-prof
  libghc-time-locale-compat-dev libghc-time-locale-compat-prof libghc-tls-dev
  libghc-tls-prof libghc-transformers-base-dev libghc-transformers-base-prof
  libghc-transformers-compat-dev libghc-transformers-compat-prof
  libghc-unix-compat-dev libghc-unix-compat-prof
  libghc-unordered-containers-dev libghc-unordered-containers-prof
  libghc-uri-bytestring-dev libghc-uri-bytestring-prof libghc-utf8-string-dev
  libghc-utf8-string-prof libghc-uuid-types-dev libghc-uuid-types-prof
  libghc-vault-dev libghc-vault-prof libghc-vector-dev libghc-vector-prof
  libghc-vector-th-unbox-dev libghc-vector-th-unbox-prof libghc-void-dev
  libghc-void-prof libghc-wai-dev libghc-wai-extra-dev libghc-wai-extra-prof
  libghc-wai-logger-dev libghc-wai-logger-prof libghc-wai-prof libghc-warp-dev
  libghc-warp-prof libghc-wl-pprint-text-dev libghc-wl-pprint-text-prof
  libghc-x509-dev libghc-x509-prof libghc-x509-store-dev
  libghc-x509-store-prof libghc-x509-system-dev libghc-x509-system-prof
  libghc-x509-validation-dev libghc-x509-validation-prof
  libghc-xdg-basedir-dev libghc-xdg-basedir-prof libghc-xml-conduit-dev
  libghc-xml-conduit-prof libghc-xml-dev libghc-xml-prof libghc-xml-types-dev
  libghc-xml-types-prof libghc-yaml-dev libghc-yaml-prof libghc-yesod-core-dev
  libghc-yesod-core-prof libghc-yi-core-dev libghc-yi-core-prof
  libghc-yi-language-dev libghc-yi-language-prof libghc-yi-rope-dev
  libghc-yi-rope-prof libghc-zip-archive-dev libghc-zip-archive-prof
  libghc-zlib-bindings-dev libghc-zlib-bindings-prof libghc-zlib-dev
  libghc-zlib-prof libglib2.0-dev libglib2.0-dev-bin libgmp-dev libgmpxx4ldbl
  libgraphite2-dev libharfbuzz-dev libharfbuzz-gobject0 libicu-dev
  libicu-le-hb-dev libicu-le-hb0 libiculx60 libid3-tools libiksemel3
  libjs-mathjax liblirc0 libltdl-dev liblua5.1-0 liblua5.1-0-dev
  libluajit-5.1-2 libluajit-5.1-common libluajit-5.1-dev libncurses5-dev
  libodbc1 libopencore-amrnb0 libopencore-amrwb0 libpcre16-3 libpcre3-dev
  libpcre32-3 libpcrecpp0v5 libpj2 libpjlib-util2 libpjmedia2 libpjnath2
  libpjsip-simple2 libpjsip-ua2 libpjsip2 libportaudio2 libpq5 libradcli4
  libreadline-dev libresample1 libsox-fmt-alsa libsox-fmt-base libsox3
  libspandsp2 libsqlite0 libsrtp2-1 libsybdb5 libtinfo-dev libtool libtool-bin
  liburiparser1 libusb-0.1-4 libvo-amrwbenc0 libyaml-dev lirc nettle-dev
  ocaml-base-nox ocaml-compiler-libs ocaml-findlib ocaml-interp ocaml-nox
  pkg-config python-iso8601 python3-iso8601 sox tk8.6-blt2.5

1 Answer 1

3

Your command installed haskell because it is a badly formed command. As the installation log says:

Note, selecting ... for regex '3.8'

because sudo apt install python 3.8 splits python3.8 into two separate arguments, python and 3.8 which is a typo error that caused 2GB of unnecessary packages to be installed. All the packages that are listed after The following additional packages will be installed: didn't need to be installed and can be safely removed with sudo apt remove followed by the whole list of packages that didn't need to be installed.

The commands to install Python 3.8 in Ubuntu 18.04 are:

sudo update
sudo apt install python3.8
1
  • Thanks. I think that using regex instead of exact match for package install is counterintuitive and dangerous. One typo and...surprise! Commented May 11, 2020 at 8:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .