94

In my freshly installed Ubuntu 20.04 LTS, Ubuntu Software is not loading properly.

It is loading only Editor's Picks but nothing else. Installed tab is empty and search is not working as well. My internet connection is perfectly working and I am not using any firewall.

1

8 Answers 8

181

On Ubuntu 20.04LTS the app called "Ubuntu software" is in reality snap-store (the terminal command running it is "snap-store", not "gnome-software"). Ubuntu 20.04 does not seem to come with gnome-software installed by default. For me, closing the app, then typing

killall snap-store

in a terminal and then re-launching the app solved the problem without a reboot.

7
  • 9
    Solved the issue Commented Nov 16, 2020 at 11:12
  • 1
    This solved the issue for me, thanks so much @arnaud
    – davidawad
    Commented Sep 7, 2021 at 17:41
  • 4
    For me closing the snap-store using System Monitor also worked.
    – BOT_bkcd
    Commented Sep 19, 2021 at 11:53
  • For me it was also the solution.
    – Lv2eof
    Commented Dec 10, 2021 at 10:21
  • 1
    This also works for me. But I wonder why the original problem happens tho at the first place?
    – Jason
    Commented May 1, 2023 at 8:22
20

If all images and software aren't loading in the software app delete the ubuntu-reviews.db file at ~/.local/share/gnome-software/ubuntu-reviews.db. It will be recreated automatically the next time you open Ubuntu Software (the Software app). Open the terminal and type:

killall gnome-software
mkdir -p ~/.local/share/gnome-software/
cd ~/.local/share/gnome-software/
mv ubuntu-reviews.db ubuntu-reviews.db.bak # skip if ubuntu-reviews.db doesn't exist

Then reopen the Software app.

If it still doesn't work you could try reinstalling the Software app.

sudo apt update
sudo apt purge gnome-software
sudo apt install gnome-software
5
  • gnome-software: no process found I am getting this.
    – digiwizkid
    Commented May 11, 2020 at 11:51
  • That means that Ubuntu Software is already closed, so continue to the next command.
    – karel
    Commented May 11, 2020 at 11:52
  • 3
    No such file or directory ~/.local/share/gnome-software/, please note: I am using 20.04
    – digiwizkid
    Commented May 11, 2020 at 11:56
  • I edited my answer.
    – karel
    Commented May 11, 2020 at 12:04
  • 1
    gnome software is not installed by default on Ubuntu 20.04LTS. What is referred to as "Ubuntu Software" in the app list corresponds in fact to the terminal command snap-store.
    – Arnaud
    Commented Nov 10, 2020 at 10:44
18

In Ubuntu 20.04, it is installed as a snap package named snap-store (not as debian package).

Reinstalling the snap package solved the issue for me. For me it wasn't opening at all.

snap remove snap-store
snap install snap-store
3
  • removing and reinstalling snap-store fixed the problem for me.
    – alabamatoy
    Commented Aug 30, 2022 at 12:29
  • worked for me too Commented Mar 19, 2023 at 10:02
  • thanks worked for me
    – swxxii
    Commented Oct 30, 2023 at 4:37
12

The only thing that has worked so far is

gnome-software refresh

But the terminal has to be kept open. Once it is closed, the apps disappear again.

Update: G. Koçmarlı has posted a working solution on Ubuntu software shows only editors picks 20.04.

10

If you're getting unresponsive search, try reinstalling the software center.

sudo apt reinstall gnome-software
1
  • It says: Package gnome-software is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source Commented Jul 29, 2021 at 7:54
9

All I did was use the command:

gnome-software refresh

and it worked.

4
  • No matching snaps for "gnome-software"
    – karel
    Commented Nov 3, 2020 at 22:38
  • Sorry guys who downvote this answer, but this was the only one that works for me. So I upvote this.
    – Alex8752
    Commented Nov 9, 2020 at 14:31
  • This worked for me
    – Jatin
    Commented Jun 25, 2021 at 19:57
  • Only solution that worked for me. Commented Feb 12, 2022 at 11:19
6

I also freshly installed Ubuntu 20.04 and was having problems with Ubuntu Software.

Run

sudo apt install gnome-software
1
  • I started testing the answers beginning from the simplest ones. This was the second answer tested and the one that worked for me. Commented Oct 28, 2021 at 18:28
3

Instead of installing the gnome-software try:

(Ubuntu has this by default but still you may not have it)This installs the snapd package manager wich ubuntu software uses

sudo apt update
sudo apt install snapd

This installs the snap store using the package manager

sudo apt-get update
sudo snap install snap-store

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .