18

I'm running Ubuntu 20.04 LTS with LVM and UEFI on a Thinkpad T480.

Whenever I run sudo update-grub, I get this output:

Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
Found linux image: /boot/vmlinuz-5.4.0-29-generic
Found initrd image: /boot/initrd.img-5.4.0-29-generic
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
Found linux image: /boot/vmlinuz-5.4.0-28-generic
Found initrd image: /boot/initrd.img-5.4.0-28-generic
Found linux image: /boot/vmlinuz-5.4.0-21-generic
Found initrd image: /boot/initrd.img-5.4.0-21-generic
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
  /dev/sdb: open failed: No medium found
Adding boot menu entry for UEFI Firmware Settings
done

My changes do not appear to take effect after running the command.

I don't have a volume called /dev/sdb...I don't understand why it would look for that.

How can I fix this issue?

Thanks in advance.

3
  • 1
  • @mook765 I tried out your link, and it stopped the errors, but my changes to grub still do not appear to take effect. May 11, 2020 at 2:22
  • 1
    I realized that the error that update-grub gave me and the issue with my changes not taking effect were unrelated. I fixed this issue by following this comment: I added the line GRUB_RECORDFAIL_TIMEOUT=$GRUB_TIMEOUT to my grub configuration. May 11, 2020 at 2:33

1 Answer 1

12

Solution from this comment on launchpad bug report:

Add a global_filter = [ "r|/dev/sda|", "r|/dev/sdb|" ] to the file /etc/lvm/lvm.conf :

 143         # Example
 144         # Accept every block device:
 145         # filter = [ "a|.*|" ]
 146         # Reject the cdrom drive:
 147         # filter = [ "r|/dev/cdrom|" ]
 148         # Work with just loopback devices, e.g. for testing:
 149         # filter = [ "a|loop|", "r|.*|" ]
 150         # Accept all loop devices and ide drives except hdc:
 151         # filter = [ "a|loop|", "r|/dev/hdc|", "a|/dev/ide|", "r|.*|" ]
 152         # Use anchors to be very specific:
 153         # filter = [ "a|^/dev/hda8$|", "r|.*|" ]
 154         # 
 155         # This configuration option has an automatic default value.
 156         # filter = [ "a|.*|" ]
 157         global_filter = [ "r|/dev/sda|", "r|/dev/sdb|" ]

When you ran sudo update-grub before applying that modification, you had this error:

Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
GRUB-Konfigurationsdatei wird erstellt …
  /dev/sda: open failed: No medium found
  /dev/sda: open failed: No medium found
  .
  .
  .
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-52-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-52-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-48-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-48-generic
  /dev/sda: open failed: No medium found
  .
  .
  .
Startmenüeintrag für UEFI-Firmware-Einstellungen wird hinzugefügt erledigt

After you apply the modification and you run again sudo update-grub, the error should be gone:

Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
GRUB-Konfigurationsdatei wird erstellt …
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-52-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-52-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-48-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-48-generic
Startmenüeintrag für UEFI-Firmware-Einstellungen wird hinzugefügt erledigt
1
  • 4
    Instead of global_filter = [ "r|/dev/sda|", "r|/dev/sdb|" ] you could use [ "r|/dev/sd[a-b]|" ]
    – spacebiker
    Apr 21, 2021 at 13:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .