7

I recently updated my Ubuntu 19 to 20.04 and started experiencing strange issue: when I open sound settings and switch "output device" while my headphones are plugged in - sound goes out of headphones no matter what device I have chosen. The only thing, which seem to help, is plugging off my headphones.

This was not the case with Ubuntu 19. I could easily switch between built-in speakers on my laptop and headphones in the settings and it worked fine.

Has anyone else encountered such issue? Is there a way to fix it?

I believe my Ubuntu was 19.10 (but I am not sure about the minor version). My kernel seem unchanged after upgrade - 5.4.0-29-generic. The hardware, obviously, haven't changed either.

  • exactly the same for me - I'm using a Dell XPS 13 and I've just upgraded from 18.04 LTS to 20.04 LTS. I have 5 output audio devices listed and the sound settings panel works fine unless the Sennheiser USB headset is plugged in, in which case the sound always comes out of that. – Andy Oct 1 at 16:11
  • I think I have the same issue. Upgraded from 18.04 to 20.04 on a custom built tower. I have 2 audio output devices, one of which is a usb headset. When I change the Output device any active music continues to play in the device it was already using. I have checked, and do not have gnome-alsamixer installed. – DeveloperWeeks Nov 2 at 18:01
4

Try installing pavucontrol and change your output device there:

sudo apt install pavucontrol
pavucontrol 

Worked for me so far as a quick fix but I can't tell you about the reasons why it works. Now I'm also able to switch output devices via the default sound settings again.

Some people also experience problems when timidity is installed.

You might want to have a look at these questions:

20.04: internal speaker (Audio) is not working in Ubuntu 20.04 LTS after upgrading from Ubuntu 18.04 LTS

No sound - Ubuntu 20.04 lts

| improve this answer | |
  • So far it works, but it is so strange: inside pvaucontrol I have to select my "Built-in Audio Analog Stereo" as fallback device (green check) and also select Port: "Speakers (plugged in)" and this is the only device where there are 2 ports. And to switch back to headphones I have to select Port: "Headphones (unplugged)", which automatically unchecks the "fallback device" mark. So strange. I hope they fix it someday. – jtheterrible May 19 at 21:46
  • Hmm, like you I found that after clicking around in pavucontrol for a bit, the standard sound settings started working. However, my USB headset now plays from the right channel only!! - the same headset works fine in so I know this isn't a hardware issue. I've also found that when trying to connect a Bluetooth headset, not only does the headset not connect properly, it causes the original problem to reappear. – Andy Oct 1 at 19:39
1

I think you might have gnome-alsamixer installed.

I had it installed in Ubuntu 18.04, and when I upgraded to 20 I started having this issue. I removed it using sudo apt-get autoremove gnome-alsamixer and it resolved the issue for me.

| improve this answer | |
  • This fixed the problem for me! – JRJurman Dec 1 at 6:29
  • Sometimes I have to change the output device/volume using PulseAudio volume control (pavcontrol) instead of the volume slider that's in Settings, but it's better than it not working at all. With gnome-alsamixer installed even pavcontrol wouldn't do anything. – Gamebuster19901 Dec 2 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.