0

So new user here, decided to change my server to ubuntu 20.04. So far i like it a lot. I'm running into an issue tho, i have multiple hard drives with tb of data all in ntfs. Don't really want to have to convert them, i figured out how to mount them automatically on startup but i can't get the right to do anything but read on them. Tried all i could find by myself on google, chmod, chown, logged as root to do those too. Mostly tried what's in here ----> https://www.linux.com/training-tutorials/how-manage-file-and-folder-permissions-linux/ I'm out of ideas. Is that possible somehow? Thanks for the help!!!

  • askubuntu.com/questions/978746/… askubuntu.com/questions/711269/… "Tried all i could find by myself on google, chmod, chown, logged as root to do those too" why do you expect LINUX/[posix instructions to work on a not-posix/WINDOW filesystem? Youi set permissions during the mounting of non-posix compliant filesystems, – Rinzwind May 10 at 20:50
  • Ok so following the links you pointed i made some progress, rather than using the disk utiliy i went and edited the fstab file and added a line like this: UUID=######### /home/Data ntfs rw,auto,users,exec,nls=utf8,umask=003,gid=1000,uid=1000 0 0 – Heliastein May 11 at 4:10
  • Obviously i'm using my real UUID and i made sure i was using the right i really am the user 1000 and in group 1000, not sure if i should look for something else i should modify. At least now when i restart and the system mount the drive it says i'm owner, it's in my group, and i can modify access i'm also able to share it, but if i try to create a new folder or to modify anything i dont really have access. Also if i try to change a permission when i go to properties/permissions it doesn't let me, i get a message like that: – Heliastein May 11 at 4:11
  • Sorry, could not change the permissions of "Data": Error settin permissions: Read-only file system. So i'm assuming i still have something to tweak somewhere. Thanks for the help so far! – Heliastein May 11 at 4:11
  • Do not use ntfs or fat. Only POSIX(compliant) filesystems use chown and chmod on files/directories. NTFS/FAT are not part of that. Permissions are set when mounting so a bad option if you want permissions to be editable per file. – Rinzwind May 11 at 6:25