152

I have a USB microphone that I can chat on Skype, record sound etc. But how can I make it so that when my mic is on and I speak, Ι hear it in speakers live without having to record my voice first and then play it back? What apps do I need or where can I enable this option?

I'm running Ubuntu 10.10

6
  • 2
    One thing to consider is that depending on your soundcard you might get latency (a slight delay between your speaking and the sound coming through your headphones). This is very disconcerting and is due to the processing and converting from Analog to Digital then back to Analog. I have heard that in Ubuntu you might need to install Jack audio libraries to reduce latency. superuser.com/questions/87571/… Apr 20, 2012 at 18:29
  • 1
    ok, but how do I get the sound coming out in first place? Apr 20, 2012 at 18:30
  • You don't need jack. I use the lowlatency kernel from Ubuntustudio that is also available through apt-get with no issues.
    – mchid
    Feb 4, 2016 at 7:14
  • 13
    Try this command: arecord | aplay
    – user619271
    Jul 2, 2016 at 15:28
  • You don't even need to do a single thing. You can just search for "online mic check". There are sites letting you hear your own voice.
    – Eray Erdin
    May 21, 2021 at 8:10

10 Answers 10

208

Here is a solution that I've tested with Pulse Audio on Ubuntu 12.04.

  • Install PulseAudio Volume Control (pavucontrol):

    sudo apt install pavucontrol
    
  • Now we will route your microphone to your speakers. Do this by running the following command:

    pactl load-module module-loopback latency_msec=1
    
  • On the Recording tab of pavucontrol, you can show all streams (combobox at the bottom) and then configure which microphone (if you have more than one) should loopback into the built-in analog stereo

To stop it running, run:

pactl unload-module module-loopback
13
  • 9
    The solution works fine, but how can I undo this setting? Dec 19, 2013 at 11:31
  • 5
    To undo it see this answer.
    – Gramic
    Feb 8, 2014 at 9:43
  • 3
    When I do this sound comes out of the speakers, but it is only static, and no voice if I speak into the mic. Any ideas? I'm on 14.04
    – andrewmh20
    Jun 10, 2014 at 17:07
  • 2
    delay ruins playback.. try to sing with it :\
    – neu-rah
    Apr 4, 2016 at 15:22
  • 3
    It still gives a slightly noticeable lag, which is annoying when playing instruments. Any way to avoid it? Nov 6, 2017 at 20:50
68

Simple solution

Just use:

arecord -f cd - | aplay -

If you wanna play while saving:

arecord -f cd - | tee output.wav | aplay -
7
  • 9
    With this solution the playback has an awful latency, unfortunately Nov 6, 2017 at 20:50
  • 17
    This will help with the latency: arecord --buffer-time=1 - | aplay --buffer-time=1 - Nov 9, 2018 at 4:46
  • 2
    Great way to record media! You can listen to it too so it's less painfully slow! Question though, how would I handle this if I have multiple mics connected (how can I select one over the other)?
    – Mark Deven
    Feb 19, 2019 at 18:30
  • 2
    a buffer time of 1ms will result in underruns. I recommend at least 20ms - make it 40ms if not using a realtime kernel.
    – Marc.2377
    Dec 12, 2019 at 0:28
  • 2
    1ms resulted in lower format, this worked for me to force specific format and sampling rate: arecord -r 192000 -f s16_le --buffer-time=1 - | aplay --buffer-time=1 -
    – chaz
    Mar 26, 2020 at 19:22
34
  1. First install PulseAudio Volume Control/pavucontrol.

    Either install via Software Manager.

    Or run this below command in terminal:

    sudo apt-get install pavucontrol
    
  2. To start Mic to Speaker working, run below command in terminal.

    pactl load-module module-loopback latency_msec=1
    
  3. To stop the same, run below command in terminal.

    pactl unload-module $(pactl list short modules | awk '$2 =="module-loopback" { print $1 }' - )
    
4
  • 2
    This solution does not work on Ubuntu Budgie 18.04 (kernel 4.20.17) on Dell Inspiron 7720
    – Marecky
    May 11, 2019 at 22:59
  • 1
    This (module-loopback) doesn't seem to work with a Focusrite Scarlett 4i4. For some reason it randomly disconnects after a second or two. module-loopback works with the built-in mic though. And the Scarlett is not broken, I can record fine in Audacity :/. May 21, 2020 at 6:29
  • In addition link to documentation freedesktop.org/wiki/Software/PulseAudio/Documentation/User/…
    – JOHN_16
    Jul 8, 2021 at 21:42
  • Woof. That was weird. It feels like it's coming in very delayed. Can I apply a negative number to latency ; ) Mar 23 at 23:23
25

You can do it with jackd and qjackctl.

The program jackd is an audio sound server daemon for Linux, and its counterpart qjackctl is a simple user interface that lets you handle JACK audio server. From this you can virtually connect the output of your mic to your speakers.

You can install them from you terminal with:

sudo apt-get install jackd qjackctl

After installing it and running qjackctl, the connections mentioned will look like the following screenshot:

qjackctl app in action

Note, I am a professional audio editor and use it each week recordings sessions.

4
  • 6
    what do I do if there's nothing under connections there.... I don't have that system - capture - playback thing.... there's nothing there.... Apr 21, 2012 at 4:13
  • 1
    I think it's not working because i have a usb mic... Apr 21, 2012 at 4:30
  • Strange... when you started qjackctl, dit it started without complaining? Apr 21, 2012 at 19:29
  • 3
    @MartinZeltin: For me it was because the jack server wasn't started. Click the 'Messages' button and look for that error in the log. To fix this I opened 'Setup' and then went to the 'Misc' tab and ticked 'Start JACK audio server on application startup'. I then closed qjackctl and reopened it. After that I could see exactly what was in the picture above
    – Baggers
    May 30, 2015 at 16:04
23

I've packaged up other people's answers into 'listen', a Bash script. Run this to listen to your mic input. It sleeps forever. Kill it (e.g. Ctrl-C) to stop listening.

#!/usr/bin/env bash

# Directs audio input (e.g. mic) to audio output (e.g. speakers),
# then sleeps forever. Stops audio redirection when it is killed.
# So, for example, plug your phone into the PC's mic, run 'listen',
# and listen to phone audio through your computer's speakers.
#
# Requires:
# sudo apt-get install pactl

set -e

module=$(pactl load-module module-loopback latency_msec=10)

function cleanup {
  pactl unload-module $module
}

trap cleanup EXIT

sleep infinity
0
8

Just an update for 2018 if you use gnome. There's a gnome extension that you can use to achieve just that. Here is the link in case anyone wants to try it out https://extensions.gnome.org/extension/954/pulseaudio-loopback-device/

2
  • Could you elaborate a little bit how to install that and how it should work? I think I have installed the extension properly (using Firefox Gnome Shell extension plugin), but nothing happened and I have no idea how to enable/configure it.
    – bluenote10
    Jan 12, 2019 at 12:21
  • Once you install it, it should make a tray icon appear. Clicking that icon should enable the mic loop. If the tray icon isn't displaying you probably need to install something like TopIcon Plus and that will probably make it appear. I'm sorry I can't be more specific but had to switch to windows and it's been a while since I used linux as a main system. Jan 31, 2019 at 18:02
3

You can use audacity to amplify your voice by "playback while recording" feature. go to edit>preferences>recording> check software playthrough.

1
  • 2
    I'm not sure that an audio recording software is the right solution to echo the microphone input to the speakers. May 10, 2017 at 13:22
2

Mixxx is awesome! I'm using it on Ubuntu (Budgie) 18.04. Quick setup, just turn it on, set up your hardware (I only had to set up the input device) and turn on the mic. You're up and running in no time with no latency, plus the ability to do tons more if you want. I dowloaded it from the software store.

0

in pactl load-module module-loopback latency_msec=1 or pactl load-module module-loopback latency_msec=1 i have 2 seconds delay...

There exist some live microphone live sign software. I have condensed usb microphone is hard to hear. (live effect will be perfect)

in mixx i hear !!! but offen clashes with the loudspeaker. is possible to put karaoke from chromium browser sond mix with microphone ?

my device is Bus 003 Device 006: ID 31b2:0011 DCMT Technology USB Condenser Microphone ubuntu 20.04

0

simple script:

 Simple convenience wrapper to record then play back a temporary sound file.
# Usage: arecord-mic duration
[[ $1 == *[![:digit:]]* ]] || return
typeset tmpFile
tmpFile=$(mktemp --suffix .wav) || return

typeset -a arecordOpts=(
    -c 1          # number of channels
    -D plughw:0,0 # device name
    -d "$1"       # duration
    -f S32_LE     # format
    -r 48000      # sample rate
    -V mono       # VU meter type
)

arecord "${arecordOpts[@]}" -- "$tmpFile" && aplay -- "$tmpFile"
rm -f -- "$tmpFile"

usage: ./arecord-mic <duration>

e.g ./arecord-mic 10 will record about 10 seconds and then plays it back.

source https://wiki.gentoo.org/wiki/ALSA

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.