18

I am a regular user of Ubuntu. I recently moved on from Ubuntu 19 for 20.04 LTS, but after the upgradation the settings is not opening. Besides the settings the display settings and change background option are not working also,

3
  • 4
    How do you try to open settings ? – Soren A May 10 '20 at 18:59
  • 1
    the answer from may 10 is the correct solution to your question,i managed to remove settings a couple of months back(i have not the faintest idea how i did it) and re installing controll center solved the problem.please accept the answer as it solves your problem. – trond hansen Jun 27 '20 at 15:21
  • 1
    @trondhansen, unless he has another problem not included in his post; my answer is not marked as correct. – Ollie Jun 27 '20 at 17:44
40

Your Gnome-Control-Center might need reinstalling. Open your terminal and enter these commands:

sudo apt-get update
sudo apt-get install --reinstall gnome-control-center

And then the commands for opening the display and system settings, respectively, would be:

gnome-control-center display
gnome-control-center

These commands will change the desktop background: First, get the URI of the background image:

gsettings get org.gnome.desktop.background picture-uri 'file:///home/yourusername/Pictures/yourpic.jpg'

Then set the background URI like so:

gsettings set org.gnome.desktop.background picture-uri 'file:///home/yourname/Pictures/yourpic.jpg'

And it will update your desktop background.

Best of luck!

2
  • 1
    I had a very similar problem (though I didn't upgrade... seems this problem occurred after an update of 20.04). Anyway the reinstall didn't fix the problem but running "gnome-control-center display" forced the display window to appear. Now using the display settings menu selection works fine, (as does the "settings' menu selection... neither of which worked previously). – MER Dec 1 '20 at 4:49
  • 1
    @MER I didn't have gnome-control-center installed. I installed it and changed my background with it and my context menu for background, settings and display settings all started to work. So this gets my upvote. – Dean Feb 19 at 17:52
2

I had a similar problem where settings would not open after an upgrade. All the updates appeared to be installed, none of the above from Ollie worked. Eventually found it was a window/screen/display problem. Try pressing "shift + win + left arrow" or similar combinations to switch displays to where the settings app is open but not visible. Then you can try a single display - I found it was set to "join" which clearly didn't work.

Not the answer you're looking for? Browse other questions tagged or ask your own question.