1

I have Xubuntu on my laptop with full disk encryption. One hard drive.

I installed Veracrypt on it a few days ago, but wanted it to autoload the encrypted file container I created. I searched online and found a site that said this:

"You merely need to add a single line (per volume you wish to auto-mount) to your crypttab file. The general format is:

volume_name /path/to/volume password tcrypt-veracrypt,tcrypt-keyfile=/path/to/keyfile

  1. The volume name is one you make up. (It gets added to /dev/mapper/ – and you’ll use that fact in a minute.)
  2. The path to your volume can either be a file (/home/user/encrypted.volume) or a block device (/dev/sdx1) or a UUID.
  3. The password can be set as none – meaning the user will need to provide it at boot (only once, still better than at every login). Alternatively, it can be a path to a file containing only the password. If you aren’t using a password and are only using one or more keyfiles – then set the password to /dev/null
  4. Since this is a VeraCrypt volume you’re auto-mounting, you need to mark it as such with the tcrypt-veracrypt option. If you’re using a keyfile, then you need to specify that and it’s location tcrypt-keyfile=/path/to/keyfile(If you’re not using keyfiles, then be sure not to copy-paste the option in… and delete the unnecessary comma, too!)

At this point, the encrypted volume will be auto-unencrypted at startup. Half the job is done. Now you just need to auto-mount it.

You’ll update your fstab: /etc/fstab with a single line per volume. The general format will look like this:

/dev/mapper/volume_name /mnt/point auto nosuid,nodev,nofail 0 0

  1. Remember that volume_name you chose earlier? Here’s another place to use it.
  2. The mount point can be anywhere you’d like.
  3. You can specify the filesystem type or leave it as auto.
  4. The rest of the options shown here just ensures others can read and write to the mounted volume."

It all seemed simple enough. I added the one line at the bottom of each file. Fairly certain I made the mount point the home directory. Then I rebooted.

It asks me for the full disk encryption password on every reboot. No problem there. Enter it and booting continues.

Gets to the line where it says: OK Started LSB : Apparmor initialization and then stalls with: A start job is running for dev-map...mycontainer.device (minutes seconds / no limit)

It hangs there forever apparently. I guess it is trying to do the autoload of mycontainer, but it doesn't ask for a password. It just hangs with the timer ticking up.

I have tried and tried to get access to the fstab and crypttab files, but since the drive is not mounted when it hangs, there is no access to the files.

I tried the live CD version of Ubuntu, Puppy, Slax trying to see if I could somehow get access in some way. No luck so far.

At one point I was able to use Gparted and mount the drive using my full disk encryption password. But it still would not let me access the files.

Is my only option a disk wipe and start over? I would really like to save the Home directory files if at all possible.

I also tried to install Ubuntu from the live CD, figuring it may give me the option to save the home directory, but it doesn't even recognize that anything is on the disk and just wants to wipe everything. So I just exit out.

Very frustrating.

  • Just fishing here, but...these instructions you are citing are for cryptsetup, not VeraCrypt, right? At least it looks like it. In the crypttab file, have you entered "password" like it was suggested or did you enter "none"? Because it only asks for the password if you enter "none", otherwise it will interpret "password" as the passphrase, which is probably not correct, so it will not decrypt. In order to correct your crypttab you will have to boot into a recovery session and edit them from there. – Sebastian May 10 at 17:28
  • This is the site I got the code from: computercorrect.com/2018/operating-systems/linux/ubuntu/… – IBMframedMain May 10 at 18:01
  • Like I said, it looks like those are instructions to use dm-crypt/cryptsetup to mount a VeraCrypt container. Verify that your crypttab is set up correctly as I explained above. – Sebastian May 10 at 18:47
  • I can get to the grub menu and choose advanced options. But when I choose recovery mode it just goes through the same process and winds up at the line with the timer ticking away. I have tried rebooting and holding the shift key down, but it doesn't bring up anything different. – IBMframedMain May 11 at 5:52
  • Well, from your description it is not clear what you tried to mount where, and which files you edited. So if recovery mode does not work, your only other option is to boot into a live session from a USB stick, and repair the files from there. – Sebastian May 11 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.