1

My laptop uses Intel graphics card but I have to use nomodeset to boot, is there anything else that I can do to boot without nomodeset?

System Specs:

Memory: 4 Gb  
Processor: Intel® Celeron(R) CPU N3060 @ 1.60GHz × 2  
Graphics Driver: llvmpipe (LLVM 9.0.1, 128 bits)  
Graphics Card: Integrated Intel Graphics Card  
OS Version: Ubuntu 20.04 LTS

I am new to Ubuntu and AskUbuntu.

Update 1:

It still freezes, But when I boot with nomodeset it says :

[    1.038310] Initramfs unpacking failed: Decoding failed    
/dev/sda5: recovering journal    
/dev/sda5: clean, 269777/781568 files, 10749001/31232256 blocks   
[    14.830987] Bluetooth: hci0: unexpected event for opcode 0xfc2f

then goes to the splash screen. It also says "System program problem detected". Do you think this could be part of the problem?

Update 2:

fsck doesn't give any errors, the bluetooth is internal, and i still get the initramfs error. I also have ' GRUB_CMDLINE_LINUX="acpi_backlight=vendor" ' instead of ' GRUB_CMDLINE_LINUX="" ' in "/etc/default/grub" to fix missing brightness sliders.

  • Why do you have to boot with nomodeset? Let me guess... it hangs at the Ubuntu logo when booting? – heynnema May 9 at 23:25
  • Yes. It just freezes. – Sushi Cat May 10 at 0:45
  • When you update this question, you have to let me know by a comment that starts with @heynnema or I'll surely miss it, like I just did. Show me sudo dmidecode -s bios-version and tell me the exact make/model of your computer. – heynnema May 10 at 14:27
  • I'm not finding what I'm looking for at the Dell web site. Give me the Service Tag ID from the bottom of the laptop. – heynnema May 10 at 17:36
  • @heynnema Bios Version: 4.4.0 and my laptop: Dell Inspiron 15-3552 – Sushi Cat May 10 at 17:38
1

You may have a problem with an older computer, with an older GPU. Try this...

sudo -H gedit /etc/gdm3/custom.conf # edit this file

change:

#WaylandEnable=false

to:

WaylandEnable=false

Save the file and quit gedit. Remove nomodeset. Then reboot.

Update #1:

You have additional problems.

fsck

  • boot to a Ubuntu Live DVD/USB in “Try Ubuntu” mode
  • open a terminal window by pressing Ctrl+Alt+T
  • type sudo fdisk -l
  • identify the /dev/sdXX device name for your "Linux Filesystem"
  • type sudo fsck -f /dev/sdXX, replacing sdXX with the number you found earlier
    • sudo fsck -f /dev/sda5
  • repeat the fsck command if there were errors
  • type reboot

crash logs

Whenever you see "System program problem detected", make sure to click either "Send Report" or "Don't Send Report", don't just close the window, or you'll see the same message over and over again.

To manually clear out the current backlog of crash reports...

sudo rm -i /var/crash/*.crash

initramfs

For the "Initramfs unpacking failed: Decoding failed" message...

sudo update-initramfs -c

bluetooth

For the "Bluetooth: hci0: unexpected event for opcode 0xfc2f" error, is this an internal bluetooth adapter, or an external USB bluetooth adapter?

Update #2:

I solved it by disabling "Load Legacy Option Rom" in the bios. Now everything works and it is detecting my graphics card.

| improve this answer | |
0

I solved it by disabling "Load Legacy Option Rom" in the bios. Now everything works and it is detecting my graphics card.

| improve this answer | |
  • Good find! Glad it's working now, – heynnema May 10 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.