In Additional Drivers under Software & Updates, the NVIDIA driver is stuck on Continue using a manually installed driver, and all other options are greyed out.

I want to set the driver to proprietary driver(nvidia-driver-390), which was originally selected before I changed it to the open source driver, but now it is stuck.

How can I resolve this issue? Should remove all NVIDIA drivers and install them again? If so , how to do it safely in Ubuntu 20.04?

Additional info:

  1. cat /var/log/Xorg.0.log output: https://termbin.com/hqo3

  2. lspci -k | grep -EA3 'VGA|3D|Display' output: https://termbin.com/bog0

  • Please edit your question and add output of lspci -k | grep -EA3 'VGA|3D|Display' terminal command.
    – Pilot6
    May 9, 2020 at 18:23
  • The proprietary dtiver is installed now. It must be a bug in GUI.
    – Pilot6
    May 9, 2020 at 18:27
  • 1
    but how can i change the driver? it is not letting me change as they are greyed out.
    – vikrant
    May 9, 2020 at 18:28
  • What do you want to change? Did you reboot?
    – Pilot6
    May 9, 2020 at 18:28
  • 1
    @Pilot6 yes that did solve the issue. now the 390 is selected, and the "continue to use a manually installed driver" option is gone. i searched quite a bit about this issue and a lot of people have gotten this issue in the past, the way they solved it involved a lot of complex steps like uninstalling and installing. I am grad it was really this simple to solve it. i have also noticed that now it is using a lot less cpu. you should post this as an answer.
    – vikrant
    May 9, 2020 at 18:41

5 Answers 5


This problem should be fixed by running

sudo ubuntu-drivers install

after a reboot.

  • 2
    This one works for me, but after reboot, my mouse becomes lag. It is like: I move my mouse from right to left, half seconds later, the mouse on the screen starts moving. Could anyone help please?
    – Franva
    Apr 7, 2021 at 23:35
  • 1
    I'm here to report that my computer just underwent this procedure and that no mouse lag was detected after reboot. My Nvidia driver went from 450 to 460 on a GeForce 920M.
    – ahmed
    Jun 19, 2021 at 15:45
  • 1
    I tried doing this and I see this: The following packages have unmet dependencies: nvidia-driver-470 : Depends: libnvidia-gl-470 (= 470.57.02-0ubuntu1) but it is not going to be installed <snip> Recommends: libnvidia-gl-470:i386 (= 470.57.02-0ubuntu1) E: Unable to correct problems, you have held broken packages.
    – drfence
    Aug 20, 2021 at 20:44
  • I see when running ubuntu-drivers -h to see the help text, the following: autoinstall Deprecated, please use "install" instead. I can't say why this is, but just something to note.
    – King Holly
    Mar 25 at 18:54
  • Works for Ubuntu 22.04.1.
    – marcelocra
    Oct 1 at 13:27

I encountered myself in a similar situation because of broken packages (Ubuntu complained on launching sudo ubuntu-drivers autoinstall; further in Software & Updates -> Additional Drivers my Nvidia graphics was locked to manual installation). I solved it like this:

  1. Remove all nvidia packages and make sure nouveau is installed (you need sudo rights):
dpkg -P $(dpkg -l | grep nvidia-driver | awk '{print $2}')
apt autoremove
apt install xserver-xorg-video-nouveau
  1. Reboot
  2. Reinstall latest nvidia packages (again, sudo rights):
ubuntu-drivers autoinstall
  • 1
    Awesome, I followed your guide and it worked, Thanks,
    – Thinh NV
    Oct 3, 2021 at 17:47
  • Seems to be the current way of getting it working in Ubuntu 22.04.1 a.k.a install Noveau drivers - reboot - install new one. Aug 19 at 15:40

I also couldn't update to a newer Nvidia driver because a manual driver was installed, in my case from 470 to 510 driver on an Focal Desktop system of Canonical.

My solution was:

  1. Open a terminal and run the command:

    sudo ubuntu-drivers autoinstall

    The above will install the newest recommended driver.

  2. Wait until all automatic commands are executed and reboot the system.

  3. The Linux kernel loaded the 510 driver.

  4. Checked Additional Drivers in Software & Updates, which points to Nvidia 510 driver.

The accidentally selected manual driver option was removed.


Here is my solution for the mouse lag situation. open NVIDIA Settings.

$ nivdia-settings

select this -> PRIME Profiles - NVIDIA (Performance Mode)

after reboot, your mouse or the animation of Ubuntu is as smooth as it used to be.


My issue is that I able to select the NVIDIA driver and after I reboot the computer I checked the info still dont detect the external GPU.

  • How is this an answer to the question? It reads like you are asking your own question. If so you do not do that this way.
    – David
    Feb 17 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.