While installing lightworks using gdeb. It prompted for that the package have unmet dependency libssl1.0.0 So i tried installing libssl1.0.0 using the following command in terminal

sudo apt install libssl1.0.0

Following message displayed in terminal

Package libssl1.0.0 is not available, but is referred to by another package.This may mean that the package is missing, has been obsoleted, or is only available from another source.

So i searched for the above package in debian & other repo. I Downloaded 'libssl1.0.0' and tried installing but i can't able to install the package. After that i found a post. In that post it was mentioned that

The package libssl1.0.0 was dropped from Ubuntu after 18.04. Newer releases of Ubuntu use the package libssl1.1. 18.04 has both packages

So i installed 'libssl1.1' Ever after installing also i am encountering unmet dependency problem.

Kindly provide me a link to install 'libss11.0.0'

Output of 'dpkg --print-architecture'


If any other details needed kindly add it in comment

  • 1
    Get libss11.0.0 at packages.ubuntu.com. – user535733 May 9 at 13:57
  • @user535733 I tried installing the libssl1.0.0 (amd64) from packages.ubuntu.com/search?keywords=libssl1.0.0. But installation failed. – A Umar Mukthar May 9 at 23:49
  • "But installation failed" doesn't tell us anything useful. Maybe you did it wrong. Maybe lots of possibilities. Provide the complete output in your question above (not in a comment). – user535733 May 10 at 0:33
  • Your question lacks a lot of information. First off, am I correct to assume that you are using Ubuntu 20.04 release? It is fully updated? Please make sure you have aptitude installed and then provide the output of apt policy libssl1.0.0 ; aptitude why libssl1.0.0;aptitude search ~i~o as an edit to your question. Pastebin the output of apt policy somewhere. Then it might be possible to actually say with confidence where the problem comes from and if there is a remedy. – MAV May 14 at 16:43

I just realized now that lightworks is not a Ubuntu package and that's of course were the mess starts. Upstreams usually do not understand packaging very well. dpkg --info lightworks-14.5.0-amd64.deb confirms that the package depends on the outdated libssl1.0.0 package which is no longer part of Ubuntu.

If you really insist on mixing outside binaries with your Ubuntu installation (you already see the headaches it leads to), you could try to install the last available version of libssl1.0.0 from bionic via cd /tmp;wget http://de.archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb; sudo dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb. This will likely create a conflict at which point you will either need to start compiling your own binaries (for such a central piece of software this will get messy VERY quickly) or decide which of the two conflicting sets of software you really want to have and which you will be living without. There's one set that needs libssl1.0 and the other set needs libss1.1 and the two packages cannot be co-installed.

One possibility at remedy is to install lightworks in a minimal virtualbox environment to avoid above-mentioned conflict. Another option is to try and use the Windows binary via wine. Third option; Apparently, there's a pre-release version based on revision 121665 released on May 06 that you can install on Ubuntu 19.04. and later that may addresses the libssl issue as they claim it does, but you need to have an account with them to download the binary so I can't verify it does. The best option is probably to ditch lightworks and their poorly packaged software ;-)

| improve this answer | |

Although not recommended, I have in the past modified a deb to remove or adjust a dependency and then chance my luck that it will work o.k. with the newer version of the dependent package:

Make a temp dir: mkdir debtemp

Unpack the deb to that dir: dpkg-deb -R debfile.deb debtemp

Edit the control file and change or just remove the dependency: vi debtemp/DEBIAN/control

Repackage: dpkg-deb -b debtemp fixed.deb

And try installing the new deb: sudo dpkg -i fixed.deb

| improve this answer | |
  • This is a bad idea. I strongly recommend against this approach. There were changes in libssl and some packages work with one but not the other. – MAV May 14 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.