7

I lost sound after updating from 19.10 to 20.04.

My sound driver appears to have been replaced with dummy output, see below

enter image description here

No other output devices are available. I have rebooted and the problem remains.

15
  • Can you change date output device by pavucontrol?
    – jarno
    May 9 '20 at 8:40
  • Does dmesg tell something about audio?
    – jarno
    May 9 '20 at 8:42
  • Sorry, I don't understand. How do I use pavucontrol? And what should I be asking dmesg? May 9 '20 at 14:55
  • In terminal install it by sudo apt install pavucontrol and thereafter run it by the same name.
    – jarno
    May 9 '20 at 14:59
  • 2
    Does this answer your question? Ubuntu 20.04 "Dummy output" No sound card in use
    – Kulfy
    Jun 28 '20 at 18:33
2

I faced the same issue, you can follow steps mentioned in the answer of this question. If the link doesn't work just do this.

Open your terminal and after that:

  1. sudo vim /etc/default/grub
  2. Find GRUB_CMDLINE_LINUX_DEFAULT and add snd_hda_intel.dmic_detect=0 to the end of it. (ex: GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 snd_hda_intel.dmic_detect=0")
  3. run sudo grub-mkconfig -o /boot/grub/grub.cfg
  4. reboot your system
2

I would first suggest rebuilding new pulseaudio configuration for your user account. This might, in most cases, fix the problem or at least rule out issues related to pulseaudio configuration.

Old pulseaudio configuration files can sometimes conflict with newer versions of pulseaudio after package or system upgrades. To fix this, please follow the steps below:

  • Back up ~/.config/pulse/ configuration directory to ~/.config/pulse_old/ by running the following command in the terminal:

    mv  ~/.config/pulse/ ~/.config/pulse_old/
    
  • After that, please reboot your system to build new pulseaudio configuration files. A new ~/.config/pulse/ directory will be created automatically.

  • Test your audio now.

If, somehow, after applying this fix you decide to go back to the previous state before applying the fix, please follow the steps below:

  1. Run the following command in the terminal:

    rm -r  ~/.config/pulse/
    
  2. Run the following command in the terminal:

    mv  ~/.config/pulse_old/ ~/.config/pulse/
    
  3. Reboot your system.

However, if all is okay and the problem is fixed, you can remove the backed up old configuration directory ~/.config/pulse_old/ to free space ( if you wish ) by running the following command in the terminal:

rm -r  ~/.config/pulse_old/
1
  • 1
    I was having a similar issue on Ubuntu 20.04. Deleting the folder ~/.config/pulse/ and restarting the system worked. Feb 26 at 15:28
1

I have found a similar problem in a different thread, you might want to try this:

It also happened to me a couple of times, though I can't remember if rebooting used to solve my problem... Anyway I found the following line to be helpful:

pulseaudio -k && sudo alsa force-reload

I can't find the original thread with the solution and explanation, but it's practically shutting/killing the deamon and forcing alsa to reload.

0

My solution is a mixed several threads: this thread and that, another one and latest:

# Edit backlist kernel:
echo "blacklist snd_soc_skl" >> /etc/modprobe.d/backlist.conf

# Edit alsa options
echo "snd-hda-intel model=generic" >>  /etc/modprobe.d/alsa-base.conf

# Edit /etc/default/grub    
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3 snd_hda_intel.dmic_detect=0"

# Reinstall alsa-base and pulseaudio    
apt-get install --reinstall alsa-base pulseaudio
alsa force-reload

# Purge timidity
apt purge timidity-daemon

# Some trick: https://askubuntu.com/a/1249071/756376
sudo setfacl -m u:$USER:rw /dev/snd/*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.