1

I am new to linux. I just baught Dell Vostro 15 3580 and I had windows 10 installed on it. I installed ubuntu 20.04 from usb. But now whenever I start my laptop , in first attempt the Dell logo doesn't disappear, and for next attempts Grub screen appears. When I select ubuntu, only a black screen appears(with NO blinking cursor in it). If I select from linux kernal option, the boot hangs at "loading ramdisk....." line (same happens for recovery mode). However, if i plug charger into my laptop before starting laptop, ubuntu loads without any problem.

Then I tried to install ubuntu 18.04. However, when I choose any option (like install , or try without install), then the screen goes off and laptop starts restarting again and again. Are there any solutions?

Note- the bios version is 1.4.1. and there is no PPT security option to be disabled in it.

1

You have BIOS 1.4.1.

Current BIOS is 1.9.0 and can be downloaded from here.

Follow the procedures listed here.

| improve this answer | |
  • Thanks. I will try it. And will definitely mark your answer as accepted if it works. – Gurbir Singh May 9 at 15:26
  • Thanks sir. It worked perfectly. – Gurbir Singh May 9 at 16:21
  • @GurbirSingh Thanks for the update! – heynnema May 9 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.