2

I'll try to be clear. I apologize if this ends up being too long.

Firstly, I HAD Ubuntu 19 in dual boot with my W10. I don't use Ubuntu that much, so I had my boot settings set to load Windows straight (that means when I power on my laptop it loads W10 like there's nothing else installed). I did this using efibootmgr, changing the boot order in there.

These days, with the 20.04 release, I wanted to update my Ubuntu, but something ("waiting for unattended-upgr to exit") would not let me give my Ubuntu its more recent updates, and I found it difficult to figure out what might have been causing this. So I decided to just perform a clean installation: I created the bootable pen-drive with the 20.04 .iso, and installed it normally over the former partitions of my 19.10 installation (of course the partitions were formatted). Everything went well. Afterwards I restarted my computer and the GRUB pops up. Like I said, I have my reasons to prefer booting my PC directly into W10 without passing through GRUB. So I went after doing that.

Here things start happening.

As I said, I barely use Ubuntu. So I was just trying to remember how to change boot order, and even after having researched a lot, I only come across "Grub Customizer" solutions. I resign and go forth. Already on Grub Customizer, I remember moving the "Windows Boot Manager" to the top. I didn't realize then that it would just change the options order when GRUB popped up when turning on my PC, instead of booting directly into Windows, as I hoped it would happen. I realized that right after rebooting the system. After some more research, then, I finally bump into "efibootmgr" somewhere, and start making my modifications. I did them, rebooted, and my W10 launched perfectly just as I wanted.

I don't know if I may have messed something using the efibootmgr, but I was trying to launch Ubuntu a few moments ago and it just won't load. I do it normally by pressing "F12" (this is a 5 years old Dell Inspiron 15 just for the record) to get into the BIOS and selecting the first "Ubuntu" option I have on my boot list (I have two options for "Ubuntu" there because of the first time I tried dual-booting my system and, after having deleted it, the option just stayed there, forever), as I always do. Problem is that it booted into Windows again, instead of loading Ubuntu. I restart again and try this other option, which is the 5th element in my boot list, right after two "Ipv4 whatsoever..." options. It boots into Windows again. I restart it one more time, and check if my "UEFI Secure Boot" Boot Option is set to OFF, and it IS. Then I try one more time the standard Ubuntu option and it just doesn't load anything, i get this dark screen until a restart my laptop pressing Power Off button. I must say I was hoping here the system would load, but after a minute or two I just gave up waiting for anything to happen. So I insert my Bootable Pen Drive, reboot my laptop again and it doesn't show up on the boot list. I try it one more time and.. nothing.

I googled similar problems but didn't manage to find something like this, and I'm not willing to go through formatting my partitions and installing Ubuntu AGAIN. If you have some tips on how fixing this through Windows, I would be grateful. I will try changing the USB port I inserted my Pen Drive in to find out if it appears in my boot list, but as for now, no "via-Ubuntu" solution is possible, I guess.

  • Why did you use the efibootmgr thingy anyway? You could have just ticked off show menu option in grub customizer and boot menu won't have shown. I don't understand what has happened but if you have nothing to lose, it is better to clean install ubuntu again and check off show menu box. You can also set default boot to windows from there too. That's what I am doing. Also you can change the extra Ubuntu option from grub customizer too. – Sasuke Uchiha May 9 at 6:35
  • I didn't know that was even a possibility. I'll wait some time for any help for a couple days and maybe do more research afterwards. In case I don't find any solution, I'll check it out. I'm actually glad you said this, I really didn't know about it. Thank you! – FelahBr May 9 at 6:42
  • Ok. Tell me how you go. Glad to help. Also, use @username when replying to comments. It will notify the person you are replying. – Sasuke Uchiha May 9 at 7:03
  • 1
    I think I found the best solution for you. You don't have to do anything with any apps or configuration files to do this. Also, you will be able to access Ubuntu through f12 as you like. All you have to do is change the boot sequence in Firmware settings. Put Windows Boot Manager to the top. Windows will boot normally and you will see no sign of Ubuntu unless you press f12. This is perfect and now I am using that method. However, I think there is something wrong with your Ubuntu install and you might have to reinstall it first. – Sasuke Uchiha May 9 at 11:05
  • 1
    After that go to grub customizer and make Ubuntu the default boot in the general setting tab. Tick off show menu and OS probe checkboxes. This will stop you from seeing grub menu even when you chose the Ubuntu option. I will add this as an answer. – Sasuke Uchiha May 9 at 11:14
1

1) I think there is a problem with your Ubuntu installation so I recommend that you re-install it.

2) All you have to do is change the boot sequence in Firmware settings. Put Windows Boot Manager to the top. Windows will boot normally and you will see no sign of Ubuntu unless you press F12.

3) After that go to grub customizer and make Ubuntu the default boot in the general setting tab. Tick off show menu and OS probe checkboxes. This will stop you from seeing grub menu even when you chose the Ubuntu option from F12. See the image below. Grub customizer

I have tested and am using this method myself.

Finally, you can delete that extra Ubuntu entry in grub customizer if you want.

EDIT: If you want to access grub menu for some reason (for example to enter Ubuntu Recovery Mode you can press Esc repeatedly after selecting Ubuntu in boot options. This will get you into the grub command-line interface. In there typenormal and press enter and press Esc again. This will get you to the grub menu.

| improve this answer | |
  • 1
    I suppose you'll get notified in your own comment without need of @ you, right? Tell me if it is necessary. And I just reinstalled Ubuntu and did as you said: I changed the boot order in the Firmware panel and it worked FINE. Also, when I log into Ubuntu from F12 it just launches the system directly, so it ended up not being necessary to use the GRUB Customizer. I appreciate your help a lot! I guess you're right, it might have been some installation bug in the previous one, except I've just re-installed, I hope it stays like that. Thank you! :D – FelahBr May 9 at 15:47
  • @FelahBr Yes, I will get notified even if you don't use @ when you are replying to my own answer. Glad to be able to help. – Sasuke Uchiha May 9 at 15:49
  • @FelahBr Also, see the edit. It may become useful later on. – Sasuke Uchiha May 9 at 16:07
  • I see it. Good to know indeed. Thanks again :) – FelahBr May 9 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.