After installing ubuntu 20.04, I have a very laggy mouse pointer. It's only visual (ie: The pointer seems to actually move in the backend. I just see it jump around in a few spots.). Dragging windows is smooth. Custom mouse pointers, such as in krita, are also smooth.

It persists over nvidia drivers and intel video drivers.I couldn't test nouveau drivers because it broke xorg altogether and I needed to use recovery to fix my system. It also persists over trackpad, trackpoint, physical mouse, and drawing tablet. The problem is nearly completely solved when connecting a second monitor.

Anyone else who has experienced this? It seems like a really weird bug and I'm not sure where to start looking for a solution. Google has given me nothing that comes close to it.

Edit: I just found out the mouse works fine on the lock screen


5 Answers 5


This happend to me, too, on my Ubuntu 20.04 installation. The mouse cursor moved smoothly on the login screen after rebooting, but started jumping after I logged in. It also was still jumpy on the login screen after locking the display.

Turns out I had accidentally turned on zooming using a keyboard shortcut. After disabling zoom in universal access, everything turned back to normal (thanks @iphipps).

A hint to zoom (or some other assistive tool) being turned on is the standing human character icon in the toolbar top right corner. The icon disappears when none of those tools are enabled.

  • Thanks! had the same problem in an ASUS Vivobook with Ryzen 3200u, and the problem is solved if I disable zoom.
    – caraca
    May 3, 2021 at 1:45

I Switched my USB Mouse from the USB 2.0 socket to USB 3.0 socket in the rear side of the Motherboard, Voila!, It worked!!! it's smooth and normal now!!!

I was also going through the ZOOM Assistive setting, mouse cursor speed up setting, none of them worked, it just came to my mind, let me try USB 3.0 socket and it worked.

  • This was driving me crazy. Thank you, thank you so much! I've been distro-hopping since weeks because of this.
    – Julien
    Aug 4, 2022 at 2:59

I encountered this after moving from 18.04 to 20.4.1. Other answers suggest turning off zoom in the accessibility menu, which worked for me too. Problem with that is when you actually need to use zoom. E.g. when apps on high pixel density screen ignore system zoom setting. (Ironically, given the name, it is the zoom.us app that was causing me problems on my high res display).

I noticed that another account on my system did not have the mouse lag problem, even when zooming. So it must be some config option in the affected account that was ok in 18.04 but not in 20.04. I have not yet identified which option causes the problem.

Current solution is to create a fresh account.

Now I have the annoying 'it draws boxes round your cursor' problem: https://bugs.launchpad.net/ubuntu/+source/meta-gnome3/+bug/1872870

also fixed by disabling zoom.


Same was happening to me Even i am using Ubuntu 18.04 but as i have wireless keyboard and mouse i have mounted moused and keyboard connector to front CPU rather than directly to motherboard ports.

Problem solved.....

No then try to update all drivers. As,it can be called Ubuntu 20 is in beta state so it will create such problems.


System is:

  • Debian 11 - Xfce4
  • NVidia GF108GL [Quadro 600]

Since a week I have a NVidia card and have the same problems with the mouse and windows going slow.
I can't remember the post where I got the tip, there I came across the following:

  • Xfce4 window tweak settings, everything checked. Your pref. settings ...

  • Compton config file in ~/.config for editing. Shadow, color, size etc.

    --shadow = false 

    --> though I have shadow enabled in window tweak settings. Otherwise I get weird transparent borders.

  • During boot/start-up I use the following command for compton:

    /usr/bin/compton --backend glx --paint-on-overlay --vsync opengl-swc

This seems to work.

  • by the way Hello 👋 ... first activity on the forum.
    – musbian
    Aug 24, 2021 at 17:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .