4

I've just set up a laptop with brand new Ubuntu 20.04 and visited Netflix in Firefox.

There was a yellow toaster underneath the address bar stating

You must enable DRM to play some audio or video on this page

So I clicked 'Enable DRM'. Then I saw "Firefox is installing components... please try again later" and after that went away I reloaded Netflix but it still would not play. When I play back video I get Netflix error F7355.

enter image description here

Then it points me to https://help.netflix.com where I can only find information on this error when I have trouble playing back on macOS or Windows. But I don't use those, I use Linux...

I understand that I can probably install Chrome which will Just Work - but I don't use Chrome. It seems like it could work but I'm missing something. What should I do to watch Netflix in Firefox on Linux on Ubuntu 20.04?

  • 1
    Make sure to follow all the steps in my answer and let me know if it works... – ldias May 8 at 16:09
  • Thanks a lot, this definitely helped. So after the above steps that I got (the DRM popup in Firefox) the DRM settings in the browser were already there and the add-ons installed. After I installed libavcodec-extra I was now also able to play back content! I wonder though, I already chose non-free install in the installation process to make sure my wifi worked. It would have been great if Ubuntu then also installed libavcodec-extra. Watching Netflix is not really an obscure use case. – MichielB May 9 at 9:08
  • I agree.. Glad to help.. – ldias May 9 at 11:48
6

You don't have DRM enabled and thus you are missing Widevine plugin to decode the DRM protected Netflix content.

  1. First make sure you have the media codecs installed

    sudo apt install libavcodec-extra
    
  2. Then enable DRM

Open Firefox and type about:preferences#content in the address bar. Look for Digital Rights Management (DRM) Content field and check the box in front of Play DRM-controlled content.

enabling DRM on firefox

This will start to install the Widevine plugin from Google. Depending on your network speed it will take a few minutes to install this add-on.

  1. Make sure that you have the required add-ons

Open a new tab in Firefox and type about:addons in the address bar. Make sure that you have Widevine and OpenH264 add-ons installed with ‘Always Active’ mode.

enter image description here

  1. Restart Firefox.

You should know be able to play Netflix via the Firefox web browser.

| improve this answer | |
  • 1
    I would not have spend such a good evening without your answer! thank you :) – JKHA Jun 28 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.