8

I need to stop ubuntuone-syncd but I don't know where to find the service that I need to stop.

4 Answers 4

9

Ubuntu One comes with the commandline tool u1sdtool to control it.

Basically the gui control panel cannot quit the syncdaemon but can connect/disconnect it.

If you need to control syncdaemon start/stop it

you have u1sdtool --start and u1sdtool --quit

If you need to connect/disconnect it

you have u1sdtool --connect and u1sdtool --disconnect commands

See u1sdtool --help for all the available commands.

You can do connect/disconnect through control panel gui as well.

There is a indicator for ubuntuone as well: What Application Indicators are available?

If you need to disable ubuntuone from autostarting at login Syncdaemon is autostart service. So if you just need to disable the autostart part when you login to your session. Go to /etc/xdg/autostart and do

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' ubuntuone-launch.desktop

and disable it from startup-applications

2
  • amazing! yes, disable ubuntuone from the start, for the moment, is my goal. thanks!
    – peppe84
    Apr 20, 2012 at 12:04
  • 1
    You do not want to edit the file in /etc/xdg/autostart directly. You should instead copy it into your ~/.config/autostart/ directory, and change the X-GNOME-Autostart-enabled key to false to disable autostart.
    – dobey
    Apr 20, 2012 at 13:20
7

Not sure if this works, but you can stop (and start) the client by using the commandos

u1sdtool --quit

u1sdtool --start

soure: Subfolders not syncing in Ubuntu One

1
  • ok. right. u1sdtool --quit stopping ubuntuone-syncdaemon
    – peppe84
    Apr 20, 2012 at 11:54
2

It seems it is is started via dbus daemon. apt-get remove ubuntuone-client will uninstall it. Or you could rename /usr/share/dbus-1/services/com.ubuntuone.SyncDaemon.service and restart dbus, that might work as well.

0

In a terminal, first list all services to ensure you call stop on the correct one:

service --status-all

then (still in the terminal)

service [insert name] stop

and to restart:

service [insert name] start

NB: the square brackets are not part of the command and should be removed :-)

1
  • 1
    Ok. Is not a service but a dbus deamon.
    – peppe84
    Apr 20, 2012 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.