1

I cannot upgrade from 18.04.4 LTS to 20.04 LTS, or indeed any later version. When I run update-manager from the GUI, it tells me the software's all up-to-date. When I run it from terminal, I get:

Failed to connect to https://changelogs.ubuntu.com/meta-release. Check your Internet connection or proxy settings

Per other dialogues here, I removed /var/lib/ubuntu-release-upgrader/release-upgrade-available and then ran

/etc/update-motd.d/91-release-upgrade and /usr/lib/ubuntu-release-upgrader/release-upgrade-motd

But neither solved the problem.

There is no issue with the router, DNS, or whatever, and I can curl https://changelogs.ubuntu.com/meta-release just fine.

To /usr/lib/python3/dist-packages/UpdateManager/Core/MetaRelease.py, I added

import ssl ssl._create_default_https_context = ssl._create_unverified_context

That got rid of the error when I run update-manager, but unfortunately didn’t trigger an upgrade, even though https://changelogs.ubuntu.com/meta-release shows versions through 19.10. And it doesn’t seem like a safe long-term fix.

Apparently, this is a known bug Failed to connect to https://changelogs.ubuntu.com/meta-release-development. Check your Internet connection or proxy settings. It’s labeled fixed on that site, but it is, of course, not fixed for me. The software updater is version 1:18.04.11.12.

A related question is why 20.04 LTS doesn’t show up on https://changelogs.ubuntu.com/meta-release. Because 20.04 LTS isn't listed, I tried Prompt=normal in /etc/update-manager/release-upgrades, in an attempt to upgrade to 18.10, 19.04, or 19.10, but update-manager still doesn’t recognize that an update is available. I just can’t get to any new version of the OS at all. Again, whether Software & Updates is set to prompt for any new release or just LTS releases, I don't get a prompt to upgrade.

This question has been asked many times, but none of the suggested Answers work for me. Is there some kind of update-manager patch available? Or, if not, how can I upgrade? I’d rather not brute-force re-install the OS.

5
  • 2
    Does this answer your question? Best way to upgrade Ubuntu 18.04 LTS to 20.04 LTS today? – user68186 May 7 '20 at 17:02
  • This is helpful; I wasn't aware of the significance of point releases. However, I had Software & Updates set to notify me of any new release, and I wasn't notified of 18.10, 19.04, or 19.10. And using the -d flag to switch to the development version causes the same error. The substance of the error seems to be "Failed to connect...Check your Internet..." rather than "You're only allowed to upgrade to the next point release, and you're not allowed to switch to the development version either." Why does update-manager fail to connect? – Dan Green May 7 '20 at 18:21
  • I infer from your comment also that 18.04 was never going to notify me of 18.10 or 19.10....that if I wanted those I would have had to wipe, format, and re-install. But why didn't the system notify me when 19.04 was available? – Dan Green May 7 '20 at 18:23
  • Yes, in Software & Updates, on the Updates tab. That graphical tool modifies the Prompt setting in /etc/update-manager/release-upgrades. Mine was set to "Prompt=normal", which correlates to the option to notify of "Any" upgrades, but I wasn't prompted. I think what I'm going to do is wait until the point release and then see if the prompt to upgrade happens. If not, I'll try the manual method again and see if the connection-failure error persists. I'll update this question in July. In the meantime, if anyone has additional insight, I'd love to hear it. Thank you. – Dan Green May 8 '20 at 16:34
  • Please edit your question and add the additional information directly in your question. Your question may be closed as a duplicate. Editing the question and distinguishing it from the duplicate is one way to save it. It seems you want to know why you were not notified of upgrade availability when 18.10 came out. – user68186 May 8 '20 at 16:43
0

You may benefit from updating the OS certificates:

sudo update-ca-certificates --fresh
export SSL_CERT_DIR=/etc/ssl/certs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.