1

I've installed Ubuntu 20.04 LTS on VMware® Workstation 15 Pro Version 15.5.2 build-15785246. The problem is that the drag and drop feature (From the host (Windows 10) to the guest (Ubuntu) on the VMware) doesn't work. I've tries the following two methods, but no success!

Method (1):

  1. sudo apt-get autoremove open-vm-tools
  2. Install VMware Tools by following the usual method (Virtual Machine --> Reinstall VMware Tools)
  3. Reboot the VM
  4. sudo apt-get install open-vm-tools
  5. sudo apt-get install open-vm-tools-desktop
  6. Reboot the VM

Method (2):

  1. Go into VM / Settings / Options / Guest Isolation
  2. Uncheck both checkboxes (Enable drag and drop, Enable copy and paste) and click OK.
  3. Shut down the guest, and shut down VMware Workstation
  4. Reboot the host computer
  5. Run VMware Workstation but do not launch the guest yet.
  6. Go into VM / Settings / Options / Guest Isolation for the guest, and
  7. CHECK both checkboxes
  8. Power On the guest.

Any idea how to solve the issue, please?

  • From the host (Windows 10) to the guest (Ubuntu) on the VMware – Franky May 7 at 14:45
1

Enter the following command in terminal to enable drag and drop between virtual machines and the host.

gsettings set org.gnome.nautilus.preferences use-experimental-views false

Do the following to enable drag and drop between two virtual machines:

  1. Open the virtual machine settings editor (VM > Settings), click the Options tab and select Guest isolation.

  2. Select Disable drag and drop to and from this virtual machine to disable the feature. Deselect it to enable the feature.

| improve this answer | |
  • 1
    I did this too, but nothing changed unfortunately! :( – Franky May 7 at 14:53
  • Try this: apt install open-vm-tools open-vm-tools-desktop. This may help. – Rasik Adhikari May 7 at 14:57
  • Run this: sudo /usr/lib/vmware-tools/bin32/vmware-user-loader & – Rasik Adhikari May 7 at 14:59
  • Errors regarding permission turned up and I added "sudo" at the beginning of the commands. Still nothing different! – Franky May 7 at 15:07
  • I've done this already. Please refer to the method (2) to the question body. – Franky May 7 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.