0

First of all I am a newbie so forgive my ignorance. Now the reason for this problem is that im using ubuntu 20.04 on a rasbperry pi, so there you first need to install the SERVER edition of ubuntu and then install the ubuntu desktop on top of the server. a side affect is that the server uses netplan while the desktop version of ubuntu uses networkmanager. Thus my ubuntu installation sees the network as unmanaged and thus.. the side effect is that I cannot enable the screen-sharing feature that I need!

I kinda found the solution but it seems temporary>

1) I edited the file

$ sudo nano /etc/netplan/*.yaml

2) I did this>

Go to /etc/netplan/01-netcfg.yaml configuration file and change it:

to add the command renderer: NetworkManager

then I apply the changed by executing

$ sudo netplan apply

the network icon appears on the top right and now its a managed network. I can now at last enable the screensharing vnc option that would not work under unmanaged network.

All is fine.. until i reboot and the 50-cloud-init.yaml goes back to the way it was without the renderer: NetworkManager entry! how can I make this change STICK and not revert back to unmanaged!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.