After upgrading Ubuntu to 20.04, gnome-calendar doesn't show the events in my Google Calendar, gnome-contacts does show the contacts which I have in Google services.

  • Release: Ubuntu 20.04
  • Package: gnome-calendar 3.36.0-1

3 Answers 3


I've installed calendar via snap (Ubuntu Software) and it didn't work, so I've removed it and installed using apt and it works (there is gnome-calendar 3.36.1-1 in apt repo).

Use the following commands in terminal:

sudo snap remove gnome-calendar
sudo apt-get install gnome-calendar
  • I tried other suggestions in this question and this is the one that made it work. Thnaks!! Feb 7, 2021 at 17:14

Looks like bug: https://bugs.launchpad.net/ubuntu/+source/gnome-calendar/+bug/1866999

  • Importance: High
  • ProblemType: Bug
  • DistroRelease: Ubuntu 20.04
  • Package: gnome-calendar 3.36.0-1
  • ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
  • Uname: Linux 5.4.0-14-generic x86_64
  • ApportVersion: 2.20.11-0ubuntu20
  • Architecture: amd64
  • CurrentDesktop: ubuntu:GNOME
  • Date: Wed Mar 11 09:47:25 2020
  • InstallationDate: Installed on 2018-02-23 (746 days ago)
  • InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180222)
  • SourcePackage: gnome-calendar

I tried uninstalling and reinstalling the gnome calendar from the terminal and it still did not sync. I had to remove my Google account completely in settings and add it again. When I brought up Calendar it synced again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .