2

I recently installed Ubuntu 12.04 (beta 2) on my HP mini 110-4117, but I cant control screen brightness. The Fn + F2 , Fn + F3 keys don't work. System Settings > Brightness and Lock doesn't provide any means of controlling screen brightness.

How can this be fixed? Thank you.

3

Here is what worked for me. I got the solution from the folowing links. Check them out or read the summary below.

http://linuxon1001p.blogspot.com/2010/03/fixing-brightness-controls.html

Desktop doesn't remember brightness settings after a reboot

Summary:

  1. Edit your /etc/default/grub file:

    sudo gedit /etc/default/grub

  2. Add the options "acpi_osi=Linux acpi_backlight=vendor" to the GRUB_CMDLINE_LINUX_DEFAULT line. It should look like this:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

    original line was:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

  3. Update grub configuration!!!! - do not forget to do this, the configuration change will not be set up if you don't run the next command:

    sudo update-grub

This worked for me after trying a lot of other solutions. I have a HP dv7-6090ef with hybrid graphics Intel/AMD.

Have fun using Ubuntu!

| improve this answer | |
  • Thanks! This solved the problem on my hp g7-1310us after 6 months with screen brightness at full blast. – klenwell Jun 24 '12 at 4:33
0

With Ubuntu 14.04, Acer E1-572, this works: Create a file /usr/share/X11/xorg.conf.d/20-intel.conf and put in it:

Section "Device"
Identifier "card0"
Driver "intel"
Option "Backlight" "intel_backlight"
BusID "PCI:0:2:0"
EndSection 
| improve this answer | |
  • The question is obviously about a HP not an Acer device. The important missing info that could make this answer relevant is the chipset model of the two. – David Foerster Oct 16 '14 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.