0

Here is my configuration, this is a default install, I have never set dns to 127.0.0.1 so that setting is somehow the best idea somebody cam up with...smh.

Can somebody tell me why the nameservers setting in netplan is ignored?

ubuntu@raspi01:~$ cat /etc/netplan/50-cloud-init.yaml
# This file is generated from information provided by the datasource.  Changes
# to it will not persist across an instance reboot.  To disable cloud-init's
# network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}
network:
    version: 2
    renderer: networkd
    ethernets:
        eth0:
            addresses:
            - 192.168.1.231/24
            dhcp4: false
            dhcp6: false
            gateway4: 192.168.1.254
            nameservers:
                addresses: [192.168.1.201]
                search: []



ubuntu@raspi01:~$ cat /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg
network: {config: disabled}



ubuntu@raspi01:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 127.0.0.1
search ******************


ubuntu@raspi01:~$ systemd-resolve --status
Global
       LLMNR setting: no
MulticastDNS setting: no
  DNSOverTLS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
  Current DNS Server: 127.0.0.1
         DNS Servers: 127.0.0.1
          DNS Domain: ************************
          DNSSEC NTA: 10.in-addr.arpa
                      16.172.in-addr.arpa
                      168.192.in-addr.arpa
                      17.172.in-addr.arpa
                      18.172.in-addr.arpa
                      19.172.in-addr.arpa
                      20.172.in-addr.arpa
                      21.172.in-addr.arpa
                      22.172.in-addr.arpa
                      23.172.in-addr.arpa
                      24.172.in-addr.arpa
                      25.172.in-addr.arpa
                      26.172.in-addr.arpa
                      27.172.in-addr.arpa
                      28.172.in-addr.arpa
                      29.172.in-addr.arpa
                      30.172.in-addr.arpa
                      31.172.in-addr.arpa
                      corp
                      d.f.ip6.arpa
                      home
                      internal
                      intranet
                      lan
                      local
                      private
                      test

Link 3 (wlan0)
      Current Scopes: none
DefaultRoute setting: no
       LLMNR setting: yes
MulticastDNS setting: no
  • Edit your question and show me ls -al /etc/resolv.conf. – heynnema May 5 at 21:51
  • I resinstalled from scratch for the fifth time and this time, somehow, resolvconf is not installed. I'm over this. It is the last Ubuntu machine I install. Thank you for your suggestion. – user1078111 May 5 at 22:06
  • 1
    I’m voting to close this question because it looks like the user deleted their account. – heynnema May 5 at 23:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy