2

I completely erased the old disk data and installed the 20.04 LTS version of Ubuntu but the Ubuntu software on the dock doesn't start. Then I ran in the terminal:

sudo apt install --reinstall ubuntu-software

It went fine. But still it doesn't open. Then I searched in dash for "software" and found two software center. One named Software and other Ubuntu Software. Software starts but Ubuntu Software doesn't start. In the dock there is Ubuntu Software which doesn't start.

Two software center

Another thing, Running sudo apt update says All packages are up to date but in the Software it shows 2 updates needed. This is strange.

software center

Why there are two software centers? One of them starts and the other doesn't. The one which starts shows pending updates but in terminal there is no pending updates.

Update: According to first answer I ran snap-store form terminal and got this:

16:30:11:0219 Gtk Failed to load module "canberra-gtk-module"
16:30:11:0225 Gtk Failed to load module "canberra-gtk-module"
16:30:14:0571 Gs  plugin appstream took 3.0 seconds to do setup
16:30:14:0580 Gs  enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, appstream, desktop-menu-path, hardcoded-blacklist, hardcoded-popular, modalias, odrs, packagekit-refine, rewrite-resource, packagekit-history, provenance, snap, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
16:30:14:0581 Gs  disabled plugins: dpkg, dummy, fedora-langpacks, fedora-pkgdb-collections, repos
16:30:16:0144 Gs  /etc/PackageKit/Vendor.conf file not found
16:30:17:0235 Gtk Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /snap/snap-store/433/data-dir/icons/Yaru/16x16/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)
Bail out! Gtk:ERROR:../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /snap/snap-store/433/data-dir/icons/Yaru/16x16/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)
Aborted (core dumped)
2

This is because the pre-installed Ubuntu Software is a snap package (source: article on OMG! Ubuntu). You can check this by running the following command:

snap list

You should see an entry called snap-store which corresponds to the pre-installed Ubuntu Software.
You are supposed to be able to run the pre-installed Ubuntu Software by running the snap-store command in Terminal. If it fails, it should show some useful error messages.

Secondly, the pending updates shown in the GUI application are updates for two pre-installed snap packages. That's why they don't appear in the list of packages that can be upgradable by apt.

| improve this answer | |
  • 1
    I have added the output of snap-store in my question. – Smie May 6 at 16:33
  • @Smie That's good, but consider reporting a bug at launchpad.net with that output instead. Your original question was why there are two software centres, I believe that is covered already. – pomsky May 6 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.