4

Whenever I boot to Ubuntu and boot into Windows again my time changes to GMT. Why is this and how can I fix this?

1

1 Answer 1

4

Your computer stores the time in a hardware clock on its motherboard. The clock keeps track of time, even when the computer is off. By default, Windows assumes the time is stored in local time, while Linux assumes the time is stored in UTC time and applies an offset. This leads to one of your operating systems showing the wrong time in a dual boot situation.

To fix this, Make Linux use to local time.

1) To make this change, first, open a Terminal window on your Linux system. Run the following command.

timedatectl set-local-rtc 1 --adjust-system-clock

2) To check your current settings, run:

timedatectl

If you see “RTC in local TZ: yes”, you are successful.

Reference

Not the answer you're looking for? Browse other questions tagged or ask your own question.