Desktop Image

desktop image here

I am unable to change the desktop icon. i tried using tweaks software but desktop icon is not changing in ubuntu 20.04. its always black and white icon. please help.

  • did you install gnome-tweaks?
    – PRATAP
    May 5, 2020 at 4:53
  • You probably have the wrong theme
    – VidathD
    May 5, 2020 at 5:50
  • Which icons do you want to change? All of them or everything except trash and files?
    – VidathD
    May 5, 2020 at 5:51
  • 1
    @PRATAP Yes I have installed gnome-tweaks and tried changing the icon through Appearance -> Icons. Only file and trash icon in dock is changing but not the desktop icons
    – JPGS
    May 5, 2020 at 22:57
  • @SasukeUchiha - Yes I tried to change all icons available in Gnome-tweaks. only icons in docks are changing, nothing changed in desktop.
    – JPGS
    May 5, 2020 at 22:58

7 Answers 7


Go to Tweaks → Extensions → Desktop Icons and select Large.

enter image description here


I had the same problem and solved it casually simply enabling dock hiding in Settings -> Appearance.


I had the same problem with some custom icons packs, I guess that the ones that you chose have not desktop icons implemented.

So I recommend you to try, for example, Numix: sudo apt install numix-icon-theme and try now to switch to it. This should change your desktop icons.

From now on, you can choose another custom icons, and if that package does not have desktop icons, you'll keep Numix ones.


Install gnome-shell-extensions to change the appearance using gnome-tweaks:

sudo apt install gnome-tweak-tool
sudo apt install gnome-shell-extensions

Then set the Yaru theme as the default:

Here is a screenshot of the correct settings.


The problem for me was high contrast in accessibility menu. Turning it off restored it to default.


I faced the same issue. You must have upgraded from 18.04 like I did. The reason for this is gnome is not isntalled properly when we upgrade.

Solution is simple. Re-install gnome 3.36 (which is what officially comes with 20.04 LTS).

sudo apt install tasksel
sudo tasksel install ubuntu-desktop

What worked for me was via Gnome Tweaks

  • Extensions
  • switch off and on Dash to panel

if one does not have the Dash to panel extension, try the same with Ubuntu dock

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .