I've got a Logitech V270 bluetooth mouse that has worked fine in the past with previous versions of Ubuntu (and other flavours of Linux, and [even] Windows). However, when I've paired it with my HP Elitebook 850 G6 running Ubuntu 20.04, the mouse stops moving the cursor when I leave it for a few seconds. Sometimes a click will wake the mouse, other times it needs a scroll on the wheel, but if I can wake it it works perfectly ... until I again leave it to type for a few seconds.

To be fair, I've never used the mouse with this computer before, so I have no idea if it would happen under Windows, but it worked perfectly with my other HP Elitebook 850 G3 running Ubuntu 16.04.

If anyone has any ideas where I could start looking at, I'd be much appreciative :)

  • Have you checked the mouse battery? When my BT mouse goes flakey, it's always the battery in my case.
    – ubfan1
    May 5, 2020 at 4:31
  • 1
    Yup, tried with fresh batteries, same thing happened :(
    – Dave
    May 5, 2020 at 8:30
  • 1
    This is the same issue I was about to post. In this case a Logi MX Master 2S and a Logi MX 705. Not only that but when moving the mouse there is some evident lag (either that or I am having some serious mental issues). May 16, 2020 at 15:38
  • I'm have the same issue after upgrade. Ubuntu becomes very unstable...
    – skonsoft
    May 29, 2020 at 12:50

3 Answers 3


And if this doesn't work do the following:


sudo nano /etc/default/grub

Completely replace line:



GRUB_CMDLINE_LINUX_DEFAULT="quiet splash btusb.enable_autosuspend=n usbcore.autosuspend=-1 usbcore.autosuspend_delay_ms=-1"

Ctrl+X for saving.

Then type:

sudo update-grub

A solution similar to that of mathias worked for me:

sudo nano /etc/default/grub

Add "btusb.enable_autosuspend=0" to the GRUB_CMDLINE_LINUX_DEFAULT line. Ctrl+X to save.

sudo update-grub

Modifying my /etc/bluetooth/input.conf solved the problem.


sudo nano /etc/bluetooth/input.conf

and modify the IdleTimeout value (in minutes) - for me 30 minutes is fine but you can set it to 0 to deactivate turning off Bluetooth.

screenshot of the file content

  • IdleTimeout value is set to 0 by default. Hence, this is not the right way to do it. Jan 20, 2022 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .