5

I unplugged my computer to do some cleaning at my desk and when I plugged it back in I could not longer boot into Ubuntu 18.04.

It sits for a minute and a half and goes into emergency mode. I ran the journal and it says:

timed out waiting for device dev-disk-by\x2duuid-246A\x2dED7E.device

Which I believe is my boot drive which is a SDD.

It then says:

dependency failed for boot/efi, Local file systems and for clean up.

Please help!

1
  • What ended up fixing the issue was booting from a drive, then running grub-repair:) Commented Dec 1, 2020 at 6:03

1 Answer 1

5

It looks like that /etc/fstab file is corrupted. So, try to fix it. If you have any other operating system installed or livecd of GNU/Linux, then boot it and mount the root filesystem of ubuntu. Now open /etc/fstab file using a text editor. As your EFI partition is not mounting, find the line which contains "/boot/efi" at the middle. Now remove "UUID=...." but do not remove whitespaces. Replace that with /dev/sda1. Note that it you have replaced sda1 with the partition id of your efi partition. If you have one SSD or HDD, it should start with sda. If it still not working, replace sda1 with sda2 then sda3... in this pattern.

1
  • Thanks, this worked miraculously!! Commented Aug 10, 2021 at 2:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .