3

For some very frustratingly unknown reason, something seems to be capturing the output of my ancient keyboard (105-key 4-pin PS2 standard, no extras) which disables regular typing keys, when using Shift+ keys for text selection. Issue remains with or without +Ctrl.

The problem is definitely software (settings) issue, as some functionality remains available (like: Shift+ or Ctrl+Alt+F#). I've sometimes managed to re-enable keys by mishap via (unnoticed) keypresses.

TL;DR:

This problem occurred on that hardware setup just within recent days, first time ever. Until then, Ubuntu has been running on it flawlessly, over several months. Probably it has been there for days, while remained unnoticed, as I really have not dealt with text editing in a week or so.

Currently I can re-enable keys by re-selecting mine keyboard language from topbar (shortcut keys: super+space). But it drives me nuts enough for repressed urge to use keyboard as bat and play some Piñata with the monitor.

No help from:

  • switching to alternate keyboard language.
  • changing keyboard to en only.
  • removing keyboard language alternatives (so just initial one from live/install CD remaining);

On reasons, I'd suspect issue to be introduced since following action (performed several days ago, and needed for currently unfinished project):

sudo apt install inxi fancontrol hddtemp

I've also done apt dist-upgrade since then.

No Gnome Addons enabled, but default Ubuntu ones (disabling them did not help either)

Gnome Tweaks is installed and I do have fiddled with it's settings, but not at the time period of problem occurrence. Recently tried out to variate it's options with no prevail. Same goes to Gnome Settings.

In the end -- while issue is highly frustrating -- it also intrigues me: what, how and why did skew mine settings like that.

5
  • For clarification, keyboard gets captured upon finishing selecting the text: releasing the <kbd>Shift</kbd>. Until then cursor keys work as supposed to, I can move selection in all directions. <kbd>Shift</kbd> also act as supposed for caps. – JanarLS May 6 '20 at 14:00
  • Mine wireless usb keyboard seems to be working fine, therefore issue seems to be PS2-keyboard only?! – JanarLS May 6 '20 at 15:10
  • I have changed mine keyboard for regular 6-pin ps/2, and it everything works as expected with this keyboard. – JanarLS Jun 10 '20 at 6:48
  • I suspect issue must be with drivers, as with 4-pin keyboard issue still proveils. Probably it simply interprets/translates the key-compo in some special-way, eg media-key, also having gnome to disable cursor keys (up/down/left/right) for text boxes. – JanarLS Jun 10 '20 at 7:41
  • Keep in mind that hardware mentioned here is ancient. ps/2: en.wikipedia.org/wiki/PS/2_port Given PC also predates the Gnome3: cnet.com/products/hp-dc7600-small-form-factor But I'd consider these still relevant, at least for GNU/Linux, as it is to go OS to re purpouse thous in some way or another (From some random personal project to some less fortunate user, simply being happy to have at least that kind of system, at all). – JanarLS Jun 10 '20 at 7:53
0

https://wiki.gnome.org/Design/OS/KeyboardShortcuts and https://developer.gnome.org/hig/stable/keyboard-input.html.en
(Thanks to JanarLS for the second link) both list Keyboard Shortcuts of the current release of GNOME Shell.

I don't see Shift+Up/Down Arrow in either of those, so I must conclude that functionality was removed from GNOME Shell, or you added it with a GNOME Shell Extension or other tool, and it was never in there in the first place.

5
  • I'd recommend this link instead: developer.gnome.org/hig/stable/keyboard-input.html.en Funny enough, that neither does not list Shift + → combo for text selection, while Ctrl + X combo to cut selected text is there? – JanarLS May 4 '20 at 23:03
  • I don't understand how those links would help thou? – JanarLS May 6 '20 at 15:01
  • No, it has nothing do to with those Gnome shortcuts, I suspect you misunderstood the issue: where and how I'm using these. What I meant: when you click on somewhere in textbox (like this commenting area), for typing, and then using key combo to select text, instead of click&drag over desired text with mouse, to then to something with it, like cut it (ctrl+x). Typically you also can use up and down cursor keys to select whole line, eg: shift+up to select text from cursors position to the beginning of the line and to the new cursor position from the and of the line (above previous one). – JanarLS Jun 10 '20 at 6:42
  • I'm now curtain though, that it must be either driver or hardware issue, as everithing works as expected as I changed the keyboard, which as all 7 pins. It is still interesting thou, as this issue only has occurred on Gnome only, as all worked fine, when booted into pure terminal. – JanarLS Jun 10 '20 at 6:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.