7

I've just installed Ubuntu 20.04 on my Asus N73SV laptop. I cannot use microphone with Skype or any other sound recording apps. When I try to record I have "white noise" only.

This is my config.

$ cat /proc/asound/card0/codec* | grep Codec
Codec: Realtek ALC269VB
Codec: Intel CougarPoint HDMI
$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Additional options in /etc/modprobe.d/alsa-base.conf:

# https://help.ubuntu.com/community/HdaIntelSoundHowto
options snd-hda-intel model=laptop-amic

# https://bugzilla.kernel.org/show_bug.cgi?id=205959
options snd-intel-dspcfg dsp_driver=1

Initialization:

$ dmesg | grep hda
[    4.008259] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.008512] snd_hda_intel 0000:01:00.1: Refused to change power state, currently in D3
[    4.027969] snd_hda_intel 0000:01:00.1: Refused to change power state, currently in D3
[    4.036166] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269VB: line_outs=2 (0x1b/0x14/0x0/0x0/0x0) type:speaker
[    4.036170] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.036172] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    4.036173] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    4.036175] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
[    4.036177] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    4.036179] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x19
[    4.036182] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x18
[    4.039933] snd_hda_intel 0000:01:00.1: Disabling MSI
[    4.039994] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    4.040502] snd_hda_intel 0000:01:00.1: number of I/O streams is 30, forcing separate stream tags
[    4.149204] hdaudio hdaudioC1D0: no AFG or MFG node found
[    4.149214] hdaudio hdaudioC1D1: no AFG or MFG node found
[    4.149221] hdaudio hdaudioC1D2: no AFG or MFG node found
[    4.149227] hdaudio hdaudioC1D3: no AFG or MFG node found
[    4.149236] hdaudio hdaudioC1D4: no AFG or MFG node found
[    4.149244] hdaudio hdaudioC1D5: no AFG or MFG node found
[    4.149251] hdaudio hdaudioC1D6: no AFG or MFG node found
[    4.149257] hdaudio hdaudioC1D7: no AFG or MFG node found
[    4.149261] snd_hda_intel 0000:01:00.1: no codecs initialized

This is a recording result:

$ arecord -f S16_LE -d 5 /tmp/test-mic.wav
Recording WAVE '/tmp/test-mic.wav' : Signed 16 bit Little Endian, Rate 8000 Hz, Mono

test-mic.wav

2
  • Is this about your build in microphone?
    – ldias
    Commented May 4, 2020 at 13:50
  • 1
    @Idias , I've tried to setup both microphones - built-in & external. The same result.
    – Alex Gusev
    Commented May 4, 2020 at 13:55

3 Answers 3

9

Commands for Noise Cancelling Linux OS:After opening your terminal run the following command.

sudo nano /etc/pulse/default.pa

## Add Below line
load-module module-echo-cancel  
## Save & Close 

pulseaudio -k
pulseaudio --start 

If still not work open file again add below code end

Add these lines at the end of the file:

### Enable Echo/Noise-Cancelation
load-module module-echo-cancel aec_method=webrtc aec_args="analog_gain_control=0 digital_gain_control=1" source_name=echoCancel_source sink_name=echoCancel_sink
set-default-source echoCancel_source
set-default-sink echoCancel_sink
1
  • 2
    Second method work for me, really useful! Thx!
    – 劉恒溫
    Commented Dec 20, 2022 at 8:55
5

I was kinda able to do a workaround with my laptop, I'm not sure if it would work in your case.

I installed the "QasMixer" package via Ubuntu Software.

sudo apt-get update
sudo apt-get install qasmixer

Then in the mixer Device pane select "hw:card" and there I saw the "mic" and a "internal mic".

The one making the noise was the "mic", so I turned it down and increased the level in the "internal mic", that one works fine.

You can tune it by recording and then listen at the same time in audacity or some other app so you can adjust the appropriate levels.

I'm not sure why that is, maybe this laptop has stereo microphone or something.

enter image description here

That solved the issue for me.

1
  • Tip: Look at right hand side to choose your device to set Commented Jul 31, 2021 at 20:14
1

I also had an issue with static noise on Ubuntu 20.04. It turned out that the reason was in the power-saving settings enabled on Ubuntu.

When I disabled power-saving mode on the snd_hda_intel audio module the noise disappeared.

Step 1: Check if the power-saving is enabled on snd_hda_intel:

cat /sys/module/snd_hda_intel/parameters/power_save

If the returned value is 1, it means that the power-saving mode is enabled, and we need to set it to 0

Step 2:

sudo su
echo 0 > /sys/module/snd_hda_intel/parameters/power_save 

This is it!

Reference: https://www.makeuseof.com/fix-static-noise-from-speakers-linux/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .