1

I'm hesitant to ask this problem here because it might be considered cross-posting. However, I need to decide whether to downgrade from Lubuntu 20.04 to 18.04.

There is a bug with LibreOffice Impress where slides will have text squished together to the point of being unreadable.

Slide with squished text

The slides are fine on Ubuntu 18.04 and also on Lubuntu 18.04. However, after upgrading a lightweight laptop from Lubuntu 18.04 to 20.04 now I have this problem. The only purpose of this laptop is for presentations so it's a pretty big deal.

The bug was posted on LibreOffice's Bugzilla two weeks ago and there has been no forward movement on it. So, I realize that will take time.

My question is, is there anyone who has seen this or has some idea on how it can be fixed, perhaps some workaround so I don't need to install Lubuntu 18.04 again?

13
  • 1
    One alternative could be to uninstall LibreOffice completely and then install the version that works for you: libreoffice.org/download/download
    – DK Bose
    May 4, 2020 at 9:07
  • 1
    I'm assuming you are talking about the default packaged version, have you tried the snap version (6.4.3.2). snapcraft.io/libreoffice (I don't know if it has your issue, but it's what I'd try first).
    – guiverc
    May 4, 2020 at 9:12
  • @DKBose So you mean just downgrade LibreOffice point by point until I (hopefully) find a version that works on Lubuntu 20.04? If that amount of work is needed, it would be far less trouble just to reinstall Lubuntu 18.04.
    – John
    May 4, 2020 at 9:22
  • Maybe there are some missing fonts in the upgraded version and it ries to emulate them without success. If you install the package ubuntu-restricted-extras you will get a lot of nice fonts (and also a lot of software to play multimedia).
    – sudodus
    May 4, 2020 at 9:22
  • @sudodus Thanks for the idea. I'll try that. The font is Liberation Sans (slides were created on Ubuntu) so there should not be a problem but still, it's easy to try.
    – John
    May 4, 2020 at 9:23

2 Answers 2

1

The user @sudodus helped out the OP in chat, so thank you @sudodus

I have seen numerous bugs reported on launchpad since 20.04's launch which are being fixed by LibreOffice upstream, but I didn't look to see if this was one. The OP had reported the issue was gone once the snap version was installed, so to install it just enter

sudo snap install libreoffice

enter image description here

This will result in two versions of LibreOffice installed (original deb and new snap version).

Should you want to remove the originally supplied version it consists of these packages

  • libreoffice-calc
  • libreoffice-impress
  • libreoffice-writer
  • libreoffice-base-core
  • libreoffice-gtk3
  • libreoffice-qt5
  • libreoffice-style-breeze
  • libreoffice-draw
  • libreoffice-math
  • and some libs etc

Those can be removed with

sudo apt remove libreoffice-base-core libreoffice-impress
sudo apt remove libreoffice-core libreoffice-common
sudo apt remove libreoffice-style-breeze
sudo apt autoremove
5
  • I tested the removal of packages anyway... the snap install was taking awhile to download, and I aborted that..
    – guiverc
    May 5, 2020 at 3:51
  • I still cannot remove the outer shell of libreoffice (installed by default in Lubuntu). Every other component is gone but the overall app is there. When I try sudo apt remove libreoffice-base-core it says Package 'libreoffice-base-core' is not installed, so not removed Can I manually delete it (safely)?
    – John
    May 5, 2020 at 13:33
  • My test of removal packages was based on a almost new install of Lubuntu (a QA-test install pre-release that I may have used for other support issues, I modify its wallpaper to reflect changes which has now been modified to course). I'd used a few commands (apt remove but not hitting "y" to proceed) and that was the smallest to remove what i wanted given what I saw in package dependencies). If you'd removed some already that would mean your needed commands could change. You could use dpkg -l |grep "ii libre" to list what's still installed. Let me know if you need help
    – guiverc
    May 5, 2020 at 22:34
  • It did not return anything at all. As this has been a bit involved, I have created a new question for it here.
    – John
    May 6, 2020 at 0:43
  • Sorry, I use other boxes for testing (this is now 20.10 anyway on my primary box) & hand-type the commands used into answers here when I'm happy, so my actual commands were hopefully as now listed above (except I ran sudo apt autoremove after each) . I missed the later two very relevant commands I'd when I created this answer. Sorry for missing those packages in the 'answer' as originally written. All packages could be written on the same apt remove line of course..
    – guiverc
    May 6, 2020 at 1:59
0

Comment SAL_USE_VCLPLUGIN in the /etc/xdg/xdg-Lubuntu/lxqt/session.conf file.

Solution from: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1881364

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.