All -

I am running Ubuntu 20.04 (Gnome) with the Ubuntu Studio packages installed. I'm working with a RME HDSP 9652 (Hammerfall) sound card and an ASUS HiDPI 32" screen. hdspmixer and hdspconf work as expected, but on my HiDPI screen I can barely read the text in hdspconf and the mixer in hdspmixer is practically unusable unless I hold a magnifying glass to the screen. I cannot resize the windows, either.

I have gnome running at 200% via "Settings --> Display". QT is at a factor of 2 for my photo editor (AfterShot) via export QT_AUTO_SCREEN_SCALE_FACTOR=2 in .profile in ~. Is there something similar I can do for hdspconf and hdspmixer?

  • Just because you're running Ubuntu Studio packages does not mean you're running Ubuntu Studio. This isn't an Ubuntu Studio issue at all. May 4 '20 at 22:12
  • I am unclear what issue it falls under but accepted your tag edit. However, if it was a GNOME issue, wouldn't the "Scale" setting @ 200% in "Displays" fix this? And does that make this an application specific issue, a GUI environment issue (like QT), or something else?
    – undfined
    May 5 '20 at 5:08

I found a workaround: run_scaled which is available here: https://github.com/kaueraal/run_scaled

I copied and pasted the code into gedit and saved as "run_scaled" in my home directory. Make the file executable:

chmod +X run_scaled


sudo apt install xvfb xpra


run_scaled hdspconf


run_scaled hdspmixer

Both apps are now useable, although they take a few seconds to load. I've added the commands to Startup Applications:


/home/myusername/run_scaled hdspconf


/home/myusername/run_scaled hdspmixer

Change myusername to your username.

They each take a few extra seconds to load after logging in, which is duplicated in the command line launch.

Cool script! Thanks to Alexander Kauer (kaueraal).

Edit: this does leave 2 icons in the system tray, one for each application. They could be useful...I get a whole Start menu to launch applications, plus options for scaling, and a lot more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.