1

Having a dickens of a time trying to install 20.04 via USB, attempting a dual boot alongside Win 10. I can get to the installer envrionment but it will randomly freeze after a couple of seconds in (can't get to terminal afterwards). The furtherest I have made it is the 'Something else' option. I have also tried the 'Try Ubuntu' option but it will again randomly freeze once it gets to desktop. Things I have tried:

  1. Verified the .iso;
  2. Used two different USB sticks;
  3. Disabled secureboot in bios along with enabling UEFI/Legacy;
  4. Entered 'nomodeset' in GRUB;
  5. Tried unsuccessfully with unetbootin.

My system configuration:

  • MSI MEG Z390 ACE Gaming Motherboard
  • 32 Gb RAM
  • i9 i9900kf
  • RTX 2080 Super
  • 860 EVO M.2 SATA SSD 1TB
  • Corsair K68 Keyboard
  • Logitec Wireless MX Master 2S

Is it possible that my peripherals are causing this issue? I don't have a DVD Drive, so I can't test this with a disc. Any help appreciated!

1
  • Boot to the Ubuntu Live DVD/USB, open a terminal, type sudo dmidecode -s bios-version. Do you have Windows already installed? Report back. – heynnema May 3 '20 at 23:12
0

Awesome thanks for the prompt heynnema! My BIOS was outdated, so it's good now. Guess what? Everything works now, don't know if it was the microcode revisions or what but that did the trick. Now writing this from within 20.04.Remember kids, always keep your bios up to date :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.