2

I cannot manage to make my touchscreen to work properly on a fresh installation of Ubuntu 20.04. On the login screen I can still touch the screen to select the user and the password edit box. Even in the first few seconds after login to Gnome/Ubuntu desktop the touchscreen stays responsive for a few seconds but then stops working (just enough time to start a terminal..)

Informations

  • Laptop/Convertible: HP Spectre x360 13-4230ng
  • Touchscreen: SYNAPTICS Synaptics Touch Digitizer V04 (according to xinput and evtest)
  • Driver used in the xorg-server: libinput (I tried evdev, but then even the touchpad did not respond anymore, so I switched back to libinput)

To me this seems like a strange problem with the Xorg driver, but I cannot figure out what's wrong.

Using evtest I found out that the touchscreen sends signals as long as the Xserver of the Gnome/Ubuntu session is not started yet. After that it does not send signals anymore.

The fact that I had the touchscreen working during the first session makes me quite sure that there should be a fix for this, or at least a workaround. Maybe there are some configuration files that were created during the first start of the Gnome/Ubuntu session? I tried to remove ~./config/dconf/user, but this did not help. Are there any others? Is there another Xorg driver that I could try?

Just to add some more information I append the relevant part of my Xorg.log here:

[    17.425] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 Mouse (/dev/input/event4)  
[    17.425] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: Applying InputClass "libinput pointer catchall"  
[    17.425] (II) Using input driver 'libinput' for 'SYNAPTICS Synaptics Touch Digitizer V04 Mouse'  
[    17.483] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 31 paused 0  
[    17.484] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: always reports core events  
[    17.484] (**) Option "Device" "/dev/input/event4"  
[    17.484] (**) Option "_source" "server/udev"  
[    17.487] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: is tagged by udev as: Mouse  
[    17.487] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: device is a pointer  
[    17.488] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: device removed  
[    17.488] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0/0003:06CB:16F9.0001/input/input13/event4"  
[    17.488] (II) XINPUT: Adding extended input device "SYNAPTICS Synaptics Touch Digitizer V04 Mouse" (type: MOUSE, id 10)  
[    17.488] (**) Option "AccelerationScheme" "none"  
[    17.488] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: (accel) selected scheme none/0  
[    17.488] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: (accel) acceleration factor: 2.000  
[    17.488] (**) SYNAPTICS Synaptics Touch Digitizer V04 Mouse: (accel) acceleration threshold: 4  
[    17.490] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: is tagged by udev as: Mouse  
[    17.490] (II) event4  - SYNAPTICS Synaptics Touch Digitizer V04 Mouse: device is a pointer  
[    17.491] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 Mouse (/dev/input/mouse0)  
[    17.491] (II) No input driver specified, ignoring this device.  
[    17.491] (II) This device may have been added with another device file.  
[    17.492] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 (/dev/input/event5)  
[    17.492] (**) SYNAPTICS Synaptics Touch Digitizer V04: Applying InputClass "libinput touchscreen catchall"  
[    17.492] (II) Using input driver 'libinput' for 'SYNAPTICS Synaptics Touch Digitizer V04'  
[    17.493] (II) systemd-logind: got fd for /dev/input/event5 13:69 fd 32 paused 0  
[    17.493] (**) SYNAPTICS Synaptics Touch Digitizer V04: always reports core events  
[    17.493] (**) Option "Device" "/dev/input/event5"  
[    17.493] (**) Option "_source" "server/udev"  
[    17.496] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: is tagged by udev as: Touchscreen  
[    17.496] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: device is a touch device  
[    17.496] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: device removed  
[    17.496] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0/0003:06CB:16F9.0001/input/input14/event5"  
[    17.496] (II) XINPUT: Adding extended input device "SYNAPTICS Synaptics Touch Digitizer V04" (type: TOUCHSCREEN, id 11)  
[    17.496] (**) Option "AccelerationScheme" "none"  
[    17.496] (**) SYNAPTICS Synaptics Touch Digitizer V04: (accel) selected scheme none/0  
[    17.496] (**) SYNAPTICS Synaptics Touch Digitizer V04: (accel) acceleration factor: 2.000  
[    17.497] (**) SYNAPTICS Synaptics Touch Digitizer V04: (accel) acceleration threshold: 4  
[    17.499] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: is tagged by udev as: Touchscreen  
[    17.499] (II) event5  - SYNAPTICS Synaptics Touch Digitizer V04: device is a touch device  
[    17.500] (II) config/udev: Adding input device SYNAPTICS Synaptics Touch Digitizer V04 (/dev/input/mouse1)  
[    17.500] (II) No input driver specified, ignoring this device.  
[    17.500] (II) This device may have been added with another device file.  
  • Guessing: maybe it's something to do with settings to disable touchpad while typing? – int_ua May 4 at 21:23
  • @int_ua: Good idea, but it doesn't seem so. The touchscreen becomes irresponsive before any keyboard typing. – xeliba May 4 at 21:43
  • If you have enough time and disk space you can try installing other desktop environment to check if the issue is isolated to gnome. Not sure if it will work in openbox which is one of the smallest ones. KDE should work but will take a lot of space. – int_ua May 4 at 21:46
  • 1
    Indeed, in openbox the touchscreen works: I can position the mouse pointer and click on things by touching them. But, whats wrong then with Gnome? – xeliba May 4 at 22:10
  • 1
    The output is exactly the same in openbox and gnome. Both times the touchscreen is enabled according to xinput. xinput --enable does not help in gnome. Could it be that the touchscreen driver crashes due to some request by gnome? I even checked KDE-Plasma now, but I see the same problem there (Actually it worked during the first KDE session but then stopped working in the second in the same way as in gnome). – xeliba May 4 at 23:04
0

Sorry I'm quite new here an can't comment on your post yet as it's not unlocked yet.

But i face the very similiar issue with Ubuntu 20.04 and Gnome 3.36.1 with the HP spectre x360 13-4203ng in my case.

I welcome any kind of help or idea or request to debug and find the issue, as i'd really like to have the touchscreen working again.

Thanks for all your support - Jack

| improve this answer | |
  • Is it 4203 or 4230? Do you see a "mouse" in xinput --list with a name similar to your touchscreen? Do you have psmouse serio1 errors in kernel log (dmesg -l err,warn output)? – int_ua May 11 at 19:31
  • It's the 4203 and xinput --list gives me: ⎜ ↳ SYNAPTICS Synaptics Touch Digitizer V04 Mouse id=10 [slave pointer (2)] ⎜ ↳ SYNAPTICS Synaptics Touch Digitizer V04 id=11 [slave pointer (2)] And dmesg -l doesn't give me psmouse outputs. Any idea what else to try? Thanks @int_ua – JacknJo May 12 at 20:30
  • Find the output of dmesg | grep -i serio1 here – JacknJo May 12 at 20:33
  • Ok, it looks like it's this bug, at least you have it as a mouse too: bugs.launchpad.net/bugs/1876991 Marking it as affecting you too will increase chances it will be noticed. Also you can subscribe to updates there. Is your touchpad set to be disabled with mouse? Try gsettings get org.gnome.desktop.peripherals.touchpad send-events command, Details: askubuntu.com/q/787433/20275 – int_ua May 12 at 21:51
0

Looks like it's this bug: https://bugs.launchpad.net/bugs/1876991

Marking it as affecting you too will increase chances it will be noticed. Also you can subscribe for updates there.

If your touchpad is set to be disabled with mouse you can try these settings:

GNOME: gsettings set org.gnome.desktop.peripherals.touchpad send-events enabled command, Details: How do I disable touchpad when using a mouse

KDE: System Settings > Input Devices > Touchpad > Enable/Disable > Ignored Devices > Add your "mouse" touchpad/touchscreen entry, should be already filled in as it's "connected".

| improve this answer | |
  • 1
    Tried this in Gnome but it doesn't help for my touchscreen. To be more precise, actually, I cannot find a subsection "org.gnome.desktop.peripherals.touchscreen". So i only tried "....touchpad send-events enabled". Anyway, thanks for you efforts! – xeliba May 16 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.