2

I have been running 16.04 for four years and opted to upgrade to 20.04.

I have two Buffalo Linkstation NAS devices that I've been using for years without too much difficulty. However after this upgrade, the network shares are completely unavailable to me.

I've tried the suggestions in, e.g., Can't acces NAS anymore after upgrading to 20.04 and had no luck. So far, this is my course of action:

  1. Perform a clean install (not an upgrade) of Windows 10 on the box.
  2. Perform a clean install (not an upgrade) of Ubuntu 20.04, creating a dual-boot system.
  3. Update /etc/fstab with the following, copied and pasted from the fstab file in my 16.04 environment:

    //192.168.1.2/share /mnt/FileServer cifs username=guest,uid=1000 0 0

  4. Install Samba: sudo apt-get install samba
  5. Update smb.conf file with client min protocol = NT1
  6. Restart samba: sudo service smbd restart
  7. sudo mount -a

I get this error:

mount: /media/FileServer: special device //192.168.1.2/share does not exist.

I have also tried setting the minimum protocol to CORE with no luck. I cannot find any way to affect the samba version on my Buffalo Linkstation NAS devices. Can someone please suggest something else to try?

Thanks!

2

CIFS is Linux kernel based and knows nothing about smb.conf so making changes there will have no affect on a cifs mount.

I'm going to assume the NAS is running only SMB1 so you will need to specity that in your fstab declaration by adding vers=1.0 to your list of options:

//192.168.1.2/share /mnt/FileServer cifs username=guest,uid=1000,vers=1.0 0 0

You will probably need to add another option to change the defalt security mode that SMB1 had in those days: sec=ntlm So the line becomes:

//192.168.1.2/share /mnt/FileServer cifs username=guest,uid=1000,vers=1.0,sec=ntlm 0 0

EDIT: Reason for adding vers comes from man mount.cifs for the vers option: The default since v4.13.5 is for the client and server to negotiate the highest possible version greater than or equal to 2.1. In kernels prior to v4.13, the default was 1.0. For kernels between v4.13 and v4.13.5 the default is 3.0.

The Linux kernel in Ubuntu 16.04 was accessing the NAS using vers=1.0. Now it's trying to access it between 2.1 and 3. Adding vers=1.0 overrides the default.

| improve this answer | |
  • If you check the link to askubuntu, cifs, samba, nfs solutions don't work with the NAS share in 20.04. File or directory sharing (with full samba) works well in 20.04. It's a specific NAS problem – ross minet May 4 at 13:37
  • Thank you, thank you, thank you, Morbius! Your solution has made this work for me, and I especially appreciate the extra information provided to explain what and why. It's so much better to learn why an answer is right than to just get the answer. For whatever reason, I'm not getting the problem with files showing as folders, despite the problems that others are having. I'll count my blessings on that. Apparently I don't have enough reputation here for my upvote of your answer to register, but please know that I did upvote it and that I'm grateful for your help! – user177049 May 4 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.