6

Just upgraded to 12.04 and noticed an extremely annoying issue.

While using twinview, there now appears to be a launcher on each screen. Moving the mouse between monitors and over the launcher "captures" the mouse for half a second or so, creating the perception of lag.

According to some bug reports I've read it appears that a launcher on every screen is a new "feature".

Is there any way I can get rid of the 2nd launcher? It's driving my crazy.

0

It's an option in the system settings. It's found under monitors or under apperance (I'm not sure because it only shows if you have two monitors)

|improve this answer|||||
  • I think it used to, however I should clarify that I'm using an Nvidia card, so 'Displays' doesn't exactly function correctly. I'll upload a screenshot – Numpty Apr 19 '12 at 18:10
  • imgur.com/nVa1O – Numpty Apr 19 '12 at 18:12
  • But if it identifies your second monitor (what it must else there was no second launcher) the option also has to show up... Are you sure there is no option? – jplatte Apr 19 '12 at 18:13
  • 2
    Just realized thanks to jP_wanN that "sticky edges" is the issue that I'm having. It seems that there is a bug when it's enabled...it ignores launcher placement. Thanks for getting me to that screen jP :) Disabling sticky edges stops the lag – Numpty Apr 19 '12 at 18:13
  • You can see in the screenshot that it only sees one gigantic screen :( – Numpty Apr 19 '12 at 18:14
4

It's under System Settings, Display, Sticky Edges. You have to set this to off.

|improve this answer|||||
  • You're a little late to the party, but thanks :) – Numpty Apr 26 '12 at 15:47
2

You also have to set 'Edge stop velocity" (in CCSM) to something very low but greater than 1.

For an idea of suitable values:

  • At "1", neither launcher appears, at a high value the launcher in the middle absorbs some of the momentum from the mouse so although not sticky it does cause a momentary check to movement.
  • At "3", which I use, it is no longer a nuisance, I'd recommend a simlar choice of number.
|improve this answer|||||
0

Answering your second question: You can't disable the second launcher, because Unity fails to detect your Twinview configuration. If it were detecting it you would have an option to choose where to show the launcher in your Display configuration.

For reference: I'm having the same issue and it seems to be a know problem.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.