I recently upgraded to Ubuntu 20.04 and today, after turning on my computer, by default, Ubuntu showed that welcome screen where you create your user and whatever. I thought my OS crashed because it did not show the login screen.

So I created a new user, and noted that all my applications were already installed in this distro, so I clicked on logout, and to login again, my real user was not listed, but if I click on "Not listed?" and type my credentials, I can log in normally into my current user.

enter image description here

Pretty weird.

This is my Settings > User page, this user on the print is the one I created, but the one that's my real user which I am logged in rn, it's not here aswell.

Have anyone faced this issue before?

Edit1 - my /etc/passwd

list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/usr/sbin/nologin
systemd-network:x:100:102:systemd Network Management,,,:/run/systemd:/usr/sbin/nologin
systemd-resolve:x:101:103:systemd Resolver,,,:/run/systemd:/usr/sbin/nologin
systemd-timesync:x:102:104:systemd Time Synchronization,,,:/run/systemd:/usr/sbin/nologin
tss:x:106:111:TPM software stack,,,:/var/lib/tpm:/bin/false
avahi-autoipd:x:109:116:Avahi autoip daemon,,,:/var/lib/avahi-autoipd:/usr/sbin/nologin
usbmux:x:110:46:usbmux daemon,,,:/var/lib/usbmux:/usr/sbin/nologin
cups-pk-helper:x:113:120:user for cups-pk-helper service,,,:/home/cups-pk-helper:/usr/sbin/nologin
speech-dispatcher:x:114:29:Speech Dispatcher,,,:/run/speech-dispatcher:/bin/false
avahi:x:115:121:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/usr/sbin/nologin
kernoops:x:116:65534:Kernel Oops Tracking Daemon,,,:/:/usr/sbin/nologin
nm-openvpn:x:118:124:NetworkManager OpenVPN,,,:/var/lib/openvpn/chroot:/usr/sbin/nologin
hplip:x:119:7:HPLIP system user,,,:/run/hplip:/bin/false
colord:x:121:126:colord colour management daemon,,,:/var/lib/colord:/usr/sbin/nologin
pulse:x:123:128:PulseAudio daemon,,,:/var/run/pulse:/usr/sbin/nologin
gdm:x:125:130:Gnome Display Manager:/var/lib/gdm3:/bin/false
jvbs:x:1000:1000:João Vitor,,,:/home/jvbs:/usr/bin/zsh
nvidia-persistenced:x:126:133:NVIDIA Persistence Daemon,,,:/nonexistent:/usr/sbin/nologin
systemd-coredump:x:999:999:systemd Core Dumper:/:/usr/sbin/nologin
mysql:x:127:135:MySQL Server,,,:/nonexistent:/bin/false
joaovitor:x:1001:1001:João Vitor,,,:/home/joaovitor:/bin/bash


  • So I can replicate the behaviour editing the /etc/passwd file. Could you post it? cat /etc/passwd and copy paste the lines of the users in question. May 2, 2020 at 20:30
  • included in my question @schrodigerscatcuriosity May 2, 2020 at 23:09
  • my default user is jvbs May 2, 2020 at 23:15
  • 2
    Well ,as you can see in this line: jvbs:x:1000:1000:João Vitor,,,:/home/jvbs:/usr/bin/zsh default shell is zsh. I tested with a dummy user, and changing :/bin/bash to :/usr/bin/zsh, it disapperared. Changing :/usr/bin/zsh to :/bin/bash made appear it again. Be very careful on editing this file! May 2, 2020 at 23:23
  • 1
    I'm running out of ideas... I adviced you to ask in askubuntu when you posted in unix & linux... but now I'm not so sure. If you think you'll be luckier asking there, maybe you should, but you would have to delete this question here to avoid cross posting. Sorry I coulnd't help you so far. May 3, 2020 at 16:05

6 Answers 6


I had the same issue.

To fix that I did these steps in a terminal:

  • sudo su we need to be superuser
  • cd /var/lib/AccountsService/users here we go to the service that shows users, issue is here (at least in my case)
  • you should see multiple files, one for each of your users, including the old one that is not showed in your screen. In this file check the value of SystemAccount. If it's true, then this is the issue: it should be false.
  • if it does not help you, simply check differences between users files, the one that works with ones that don't. Also check that Icon path is correct.
  • don't forget to exit su, and reboot after each try. Good luck, it took 3h digging before a fixed my issue.
  • 1
    This fixed the issue for me! You're a life saver! Oct 22, 2020 at 20:37
  • This also fixed it for me!
    – 0atman
    Jan 11, 2021 at 20:27
  • 3
    I my case, I need change default shell the user from zsh to bash using the command sudo chsh -s /bin/bash <username> before follow this tip
    – Iago Leão
    Mar 10, 2021 at 13:09
  • Worked for me also, thanks so much!
    – Leo Simon
    Jun 24, 2021 at 1:57
  • 1
    My account also became a system account, but how? Because of do_release_upgrade? Changing it's value to false solved it. Oct 4, 2021 at 11:46

I was facing the same issue after uninstalling zsh. Your default user's (jvbs–João Vitor) default shell is zsh, so was mine. I changed it using cmd sudo --shell /bin/bash username from zsh to bash, after logging out and logging in again my issue was fixed.
Hope this works for you too!


I got this error while I was trying to install zsh on Ubuntu 20.04 Command : sudo su was throwing error ("no such file or directory"). So at first I fixed this problem by editing root configuration on /etc/passwd file

It was like this before: root:x:0:0:root:/root:/usr/bin/bash

I changed it to: root:x:0:0:root:/root:/bin/bash

It fixed my sudo su error. Then I followed the steps recommended by Richard Haddad up there. It worked. Thanks.


I had this problem yesterday. Installing zsh system wide solved the problem. I don't have enough reputation to upvote appropriate responses but sudo apt get install zsh solved it.


Try finding your old account in the password file, then go change (an):x:1000:1000... (an) is your account name. I used sudo vipw in 19, but I'm not so sure about 20.04.

  • jaovitor:x:1001:1001 to jaovitor:x:1000:1000 . I forgot to search your password file Jul 30, 2020 at 10:12

I think that the issue was triggered somehow after setting zsh as default shell. I followed comments in this page and it resolved the issue for me. I first switched back to bash and then updated /var/lib/AccountsService/users/... as suggested.

  • Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful. - From Review Feb 4, 2022 at 17:44
  • Please don't add "thank you" as an answer..... Well my comment was not a thank you only. I wanted to emphasize that the issue is actually related to zsh,,, I hope that someone fixes the root cause. My comment also emphasize that the issue is still happening in 2022.
    – penny
    Feb 6, 2022 at 20:41
  • Either way the purpose of "answers" should be self-explanatory. Comments are comments, not answers. Feb 6, 2022 at 21:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .