0

Boot hangs for 30 seconds at "Begin: Running /scripts/local-premount"

Try the following:

open /etc/initramfs-tools/conf.d/resume
replace RESUME=UUID=xxx with RESUME=none
issue sudo update-initramfs -u
reboot your system

but in mine

android@inspi:/etc$ cat /etc/initramfs-tools/conf.d/resume
cat: /etc/initramfs-tools/conf.d/resume: No such file or directory

/etc/initramfs-tools/initramfs.conf

android@inspi:/etc$ cat /etc/initramfs-tools/initramfs.conf 
#
# initramfs.conf
# Configuration file for mkinitramfs(8). See initramfs.conf(5).
#
# Note that configuration options from this file can be overridden
# by config files in the /etc/initramfs-tools/conf.d directory.

#
# MODULES: [ most | netboot | dep | list ]
#
# most - Add most filesystem and all harddrive drivers.
#
# dep - Try and guess which modules to load.
#
# netboot - Add the base modules, network modules, but skip block devices.
#
# list - Only include modules from the 'additional modules' list
#

MODULES=most

#
# BUSYBOX: [ y | n | auto ]
#
# Use busybox shell and utilities.  If set to n, klibc utilities will be used.
# If set to auto (or unset), busybox will be used if installed and klibc will
# be used otherwise.
#

BUSYBOX=auto

#
# COMPCACHE_SIZE: [ "x K" | "x M" | "x G" | "x %" ]
#
# Amount of RAM to use for RAM-based compressed swap space.
#
# An empty value - compcache isn't used, or added to the initramfs at all.
# An integer and K (e.g. 65536 K) - use a number of kilobytes.
# An integer and M (e.g. 256 M) - use a number of megabytes.
# An integer and G (e.g. 1 G) - use a number of gigabytes.
# An integer and % (e.g. 50 %) - use a percentage of the amount of RAM.
#
# You can optionally install the compcache package to configure this setting
# via debconf and have userspace scripts to load and unload compcache.
#

COMPCACHE_SIZE=""

#
# COMPRESS: [ gzip | bzip2 | lz4 | lzma | lzop | xz ]
#

COMPRESS=lz4

#
# NFS Section of the config.
#

#
# DEVICE: ...
#
# Specify a specific network interface, like eth0
# Overridden by optional ip= or BOOTIF= bootarg
#

DEVICE=

#
# NFSROOT: [ auto | HOST:MOUNT ]
#

NFSROOT=auto

#
# RUNSIZE: ...
#
# The size of the /run tmpfs mount point, like 256M or 10%
# Overridden by optional initramfs.runsize= bootarg
#

RUNSIZE=10%
1
  • Did you try creating the file? in /etc/initramfs-tools/initramfs.conf says # Note that configuration options from this file can be overridden # by config files in the /etc/initramfs-tools/conf.d directory. – schrodigerscatcuriosity May 2 '20 at 14:58
0
sudo gedit /etc/initramfs-tools/conf.d/resume

RESUME=UUID=18469c87-14e0-4dca-8cb6-591d41298d1e

android@inspi:~$ sudo update-initramfs -u -k all
update-initramfs: Generating /boot/initrd.img-5.4.0-28-generic
update-initramfs: Generating /boot/initrd.img-5.4.0-26-generic
android@inspi:~$ 

android@inspi:~$ sudo lsblk -f NAME FSTYPE LABEL UUID
FSAVAIL FSUSE% MOUNTPOINT sda
├─sda1 vfat ACC7-9A1B 140.1M 52% /boot/efi ├─sda2 swap
18469c87-14e0-4dca-8cb6-591d41298d1e [SWAP] ├─sda3 ext4 3c1e55bc-8bdc-4742-912d-337da429b83f 96.1G 5% / ├─sda4
├─sda5 ntfs 80D47B63D47B59FC
└─sda6 ntfs router_data 4416017316016770 111.4G 60% /home/android/routerbin sr0
android@inspi:~$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.