I got the Ubuntu 11.10 32-bit edition and i used Unetbootin to write the ISO to a usb stick.After that i tried to boot from the stick,having changed the BIOS boot settings,and when the first interface shows up with the choices of istallation,whatever choice i select i got the message"invalid or corrupt kernel image".I use a netbook with windows 7 on it.I tried different usb sticks but same again.I also tried Universal USB installer instead of Unetbootin but same again.Any idea of what happens?I am using ASUS 1000H.The USB doesn't work in one more PC i tried to,but i also tried a second USB to both of the two computers and same again. I downloaded the ISO image once again and follow the same procedure but same again

closed as off-topic by psusi, Eric Carvalho, Braiam, Radu Rădeanu, mikewhatever Apr 30 '14 at 18:05

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – psusi, Eric Carvalho, Braiam, Radu Rădeanu, mikewhatever
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What netbook are you using? Do the same USB pens work in another PC? – Bruno Pereira Apr 19 '12 at 12:32
  • 1
    It's possible that the image you are using is corrupt. You may try downloading the image again to see if that helps. – Gary Apr 19 '12 at 13:15

You can verify downloaded Ubuntu images using md5sum. Here's a simple example to get the hash for a DVD image:

$ md5sum edubuntu-11.10-dvd-amd64.iso
f323d7e7b9686eb9c5babd94961e5df1 edubuntu-11.10-dvd-amd64.iso

Now you can compare that against the Ubuntu Hashes page. In this case they match up meaning what I downloaded matches the original copy (with 99.99something percent accuracy).

If you downloaded an ISO not on that list you can usually still find a hash but it depends on the ISO's source. If you grabbed it from the daily page, there is a MD5SUMS file in there but it obviously changes every day.

If you can't verify the image, download it again and check it right away. It might be worth using the Bittorrent download options as that has built-in checking.

The following doesn't apply to you (you've already swapped out USB sticks, strongly suggesting it's an image issue), but it might help people in the future.

If your image verifies correctly but still doesn't work, just try copying it to the USB stick again. In some cases you might find you have a stick that just refuses to work (I've had a couple of old, cheap disks not boot Ubuntu. I later found out that they were just shredding any data going in and out of them so chucked them. In other words: you might want to try another stick.

  • It probably isn’t an image problem, as this error appears to many users. Even for the ones using Bittorrent to download the image, which already has its own verification built in. I think it is a problem of Unetbootin or the like, which are not yet upgraded by the author to support the newest Ubuntu release. My solution works (selecting manually). – erik May 31 '13 at 19:50
  • I have not had good luck creating bootable USBs with unetbootin. I've switched to dd and all is good. – Marc Jun 13 '13 at 1:35

For me with Ubuntu 13.04 the solution was:

  • When the boot prompt appears with the countdown going from 10 to 0 I had to select manually »Try Ubuntu« or »Install Ubuntu« and it worked.
  • But if I waited the 10 seconds the automatic choice called »Default« was selected and then the error appeared. So: Don’t wait for the countdown, make a selection.

I created the USB stick with Unetbootin.


I've had the same error previously, I solved it by formatting my USB to Fat16 format and then using the Universal Windows Installer. Give it a try.

  • Did not work for me with Unetbootin and Ubuntu 13.04 AMD64. – erik May 31 '13 at 19:48

I had the exact same issue with Ubuntu 12.04 LTS and solved it by downloading the image from another mirror. Apparently I was downloading a corrupted file.


Please try and recreate another bootable USB installer - see official article about installing ubuntu from USB as a guide. Lastly make sure you are using a larger capacity memory stick for the bootable disk - I would recommend anything from 4GB upwards just to be sure. Good luck

Not the answer you're looking for? Browse other questions tagged or ask your own question.