I did a fresh install of Ubuntu 20.04 on a Matebook X Pro with only Intel integrated UHD Graphics 620.

Freeze happened when trying to add a new GMail account, and also at various other sites.
When I write incredible fast in search/address line the text appears unevenly with a small delay.

Also text input in browser (like where I write this) is a little bit slow, delayed, but only noticeable as I have repeat keys set very high).

I've found several years old similar treads that recommends to disable GPU acceleration. I tried it but still incurred freezes.

I tried both Chromium and Chrome and both had the same issues.

I tried Firefox and it also froze when opening many youtube videos. Whole machine froze for about 2 minutes before going back to normal. While that happened, this https://askubuntu.com page, that was open in Chrome, crashed with the following error:


  • 3
    I have been experiencing same problem after upgrading to the latest Ubuntu 20 with gnome. Google Chrome and Firefox frozen after some time. So I switched to Unity Gui (maybe kde Gui will work too) and freezing stopped. Maybe this will help someone May 5, 2020 at 7:41
  • Also experience Chromium issue (Ubuntu 20.04 + Chromium, up to date as of 2020-05-30, AMD FX8320, video nvidia GT710). In my case, Chomium just no longer render display (existing page have display frozen, new page has blank page). Mouse, KB, everything else in computer still working OK
    – Polymerase
    May 31, 2020 at 0:37
  • NVidia card, proprietary drivers. Same here, the tabs crash with the very same code. Jun 11, 2020 at 20:59

4 Answers 4


I had the same issue and disabling the hardware acceleration in Chrome fixed it for me.

To disable hardware acceleration in Google Chrome:

  1. Open Google Chrome.
  2. Go to Settings.
  3. Click on Show advanced settings and scroll to the System section.
  4. Uncheck Use hardware acceleration when available and restart Google Chrome.

enter image description here

  • 1
    I had the same issue and this worked for me.. Thanks.. Mar 2, 2021 at 14:42
  • 1
    This solution worked for me for a different problem (see bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1927205 ) The bug I encountered was that clicking on the Chromium menu (or the dropdown from my bookmars) displayed a blank window and freezed application. Since it prevented me to go to the settings through the graphic interface, I went to chrome://settings in the address bar. I use Ubuntu 21.04. Now it works seamlessly, thanks !
    – ToddEmon
    Sep 14, 2021 at 7:16
  • I have the same issue but this solution doesn't fix it (askubuntu.com/q/1491271/800252). Any idea what might help?
    – Kvothe
    Nov 2 at 16:12

Doing more troubleshooting it seems that disabling GPU acceleration in Chrome helps some, but computer still completely freezes sometimes.

I logged in using Wayland instead, and it seems to run much smoother! No freezes yet. Still GPU acceleration disabled as pages displays slower with acceleration enabled.

Anyone with a intel 620 card that face similar issues might want to give Wayland a try. Simple log out and select Wayland when loggin back in.


I've search some time and I've add --disable-software-rasterizer also. In spite of gpu disable flag included, gpu process still goes on. In my case, performance improved after inluding disable rasterizer. I am using Manjaro by the way and it seems this problem is appearing around, not sure if it's chromium/chrome related or ubuntu-based but it's broader.

Edited: Some services that use webgl might not work properly after. In my case, I use figma and gives errors and it doesnt work


I just did what Fedir Petryk suggested, namely, switched to Unity GUI. No problems so far. As an ultimate test I ran 5 youtube videos simultaneously. Worked like a charm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .