18

I recently installed Ubuntu 20.04 on my Lenovo ideaPad 530. At first I could connect to my network but after a while connection distributed and then in setting it says it couldn't find WiFi adapter. I tried to reinstall it but it doesn't seem to work.

lspci -knn | grep Net -A3; rfkill list

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter [10ec:b822] (rev ff)
    Kernel driver in use: rtw_pci
    Kernel modules: rtwpci
03:00.0 Non-Volatile memory controller [0108]: Phison Electronics Corporation E12 NVMe Controller [1987:5012] (rev 01)
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command.
    – Pilot6
    May 1, 2020 at 22:30
  • 02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter [10ec:b822] (rev ff) Kernel driver in use: rtw_pci Kernel modules: rtwpci 03:00.0 Non-Volatile memory controller [0108]: Phison Electronics Corporation E12 NVMe Controller [1987:5012] (rev 01) 0: ideapad_wlan: Wireless LAN Soft blocked: no Hard blocked: no 1: ideapad_bluetooth: Bluetooth Soft blocked: yes Hard blocked: no 2: hci0: Bluetooth Soft blocked: yes Hard blocked: no 3: phy0: Wireless LAN Soft blocked: no Hard blocked: no
    – Sadra
    Aug 8, 2020 at 9:20

6 Answers 6

26

After 2 days of searching I found the solution.

In fact, if you install Ubuntu and windows 10, your windows system will block your wifi card.

To prevent this, you have to disable the fast boot mode on windows.

this is how : https://help.uaudio.com/hc/en-us/articles/213195423-How-To-Disable-Fast-Startup-in-Windows-10

  • press the ⊞ Win + R to bring up the Run dialog, type powercfg.cpl and hit Enter
  • Click on the "Choose what the power buttons do" - tab
  • (If all check boxes are grayed out: click on the 🛡️ Changing settings requires elevated permissions and enter your admin password)
  • Untick the "Turn on fast startup (recommended)" check box.
3
  • you might have to turn on the option of fast startup in control panel. the command (in cmd terminal with admin privileges) to do that is "powercfg /hibernate on"
    – new2Ubuntu
    Jan 10, 2021 at 11:28
  • 3
    Thanks man. This one fixed my issue Jan 19, 2021 at 9:42
  • 1
    Oh thank you so much bro, I have the same issue, I have tried reinstall both window and ubuntu on my laptop, but this issue still happens. Now the wifi card on Ubuntu works well 😭 Nov 14, 2021 at 7:45
4

I was having the same problem and rectified by doing the following:

  1. Go to software and updates
  2. Disabled the proprietary wireless lan driver
  3. Restart the pc
  4. Et voilà!
3

I had a fresh installation of Ubuntu 20.04. WiFi was working during the live session, but I was getting WiFi adapter missing, after the OS installation. I saw many threads and tried few options.

  1. If you have access to wired connection, try connecting the Ethernet cable and then update the driver in 'Software & Update' which might fix the issue. If you don't have access to wired connection, you can try by using USB tethering using a phone (Android). Here is a link on how to do USB tethering. https://www.youtube.com/watch?v=LvMZW_ztf14

  2. I didn't know about the USB tethering so I tried installing drivers manually from the Ubuntu ISO file. This didn't help me and I just reinstalled my OS and everything was working.

Sorry for the long explanation. Try the first option. It must work.

1

Fixed using a tethering USB as well, but had to run software and update and 'sudo apt-get update' on the terminal for turn on the Wi-Fi. After the update the terminal shows this massage of 'delete not used puglins? ', or something like that, and I typed 'y'. It just worked after that.

0

I had this problem too (wifi adapter was not found) and I couldn’t connect to Ethernet either to even try the method above. Here’s the solution that worked for me:

1: reboot and on startup if you have 2 OS’s installed on your pc you should see an option that says “advanced options for Ubuntu”

  1. Choose that option and revert back to a previous version

After I did that, wifi and Ethernet were working again

1
  • Yes, it works for a short time, but not a long-term solution.
    – MI Nayan
    Mar 4, 2021 at 7:34
0

I was struggling with this, too, and none of the other solutions worked. What did work was running:

sudo apt-get dist-upgrade

Not the answer you're looking for? Browse other questions tagged or ask your own question.