0

Today I tried to upgrade to Focal Fossa from Bionic Beaver, and I must have made a mistake.

First I switched to "For any new version" in the Software & Updates UI.

After that things get messy. My terminal history tells me that I entered successively

RELEASE_UPGRADER_ALLOW_THIRD_PARTY=1 update-manager
RELEASE_UPGRADER_ALLOW_THIRD_PARTY=1 update-manager -d
RELEASE_UPGRADER_ALLOW_THIRD_PARTY=1 do-release-upgrade
sudo do-release-upgrade -d

I can't recall precisely, but I must have realized after the first attempt that the system was about to upgrade to 19.10 instead of 20.04, which is why I aborted. And at some point - maybe already the first attempt -, a "partial upgrade" was suggested, which I declined.

Now I'm still on 18.04 LTS, but my sources.list contains entries such as

deb http://ftp.hosteurope.de/mirror/archive.ubuntu.com/ eoan main restricted

And, not surprisingly, when I run sudo apt update, the output tells me that

...
Hit:4 http://ftp.hosteurope.de/mirror/archive.ubuntu.com eoan-updates InRelease
...
2551 packages can be upgraded. Run 'apt list --upgradable' to see them.

Can anyone help me fix the wrong sources list and cleanly upgrade from 18.04 to 20.04? It would be much appreciated!

  • 1
    A "partial upgrade" is bad news. It means you have packages (often from a non-Ubuntu source) that conflict with the upgrade. Best practice is to remove those non-Ubuntu packages before starting a release-upgrade. 1) Back up your data - you are creeping close to reinstall. 2) If you know how, locate and remove those non-Ubuntu packages. Then complete the upgrade using --fix missing. If you don't know how, then clarify if you want to take the time to learn. If you don't want to invest the time, then reinstall. – user535733 May 1 at 12:22
  • @user535733 Thank you. Do you think the "partial upgrade" is a result of using the RELEASE_UPGRADER_ALLOW_THIRD_PARTY=1 flag? And: It would not suffice to "repair" my sources.list, disable all third-party PPAs and try again? – Turtle May 1 at 12:33
  • In general, the presence of non-Ubuntu packages is the big problem, not the flag. Example: If 18.04 has Foo 1.1, and 20.04 has Foo 1.2.0, and the non-Ubuntu source has Foo 1.2.1, then on 18.04 you get bleeding-edge software. But that version 1.2.1 will conflict when you try to release-upgrade to 20.04; everything that needs Foo 1.2.0 will fail to install and you will get offered a partial-upgrade instead. – user535733 May 1 at 12:42
  • My opinion would be to backup important data and do a clean install from USB. System can maybe be fixed, but maybe not completely and might give problems after. – crip659 May 1 at 13:02
  • 1
    Most of them should be listed in software and updates under other software. Read each line carefully to see. – crip659 May 1 at 15:17
0

Depending on when you aborted it is possible the release upgrader did not have the opportunity to reset your sources.list entries back to bionic. There may be a backed up file in /etc/apt/ called sources.list.distUpgrade, check the contents of that file and if they match your expectations replace sources.list with it.

With regards to "Any new version" that means then next supported release of Ubuntu which is 19.10 if you are running Ubuntu 18.04 LTS. If you want to upgrade to Ubuntu 20.04 LTS you'll want to set the option to "For long-term support versions". However, release upgrades to 20.04 LTS from 18.04 LTS won't be enabled until late July 2020.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.