5

So I updated my Ubuntu to 20.04 and many small squares with random pixel colors often appear on my desktop background. They are not glued to my screen though; they only appear on desktop. I've attached a screenshot.

screenshot.

What can I do?

PS: This has never happened on Windows, so I guess it must be OS-related.

Workaround: Restarting Gnome with Alt+F2 and then entering r solves the problem but only until the next restart.

Update: I changed the driver to NVIDIA's driver and still no luck. Some other random pixels are now on the background. And they remained there even after I changed the driver back to X.Org X server. And one other thing, those pixels go away when I change the background, but they come back the next time Ubuntu starts. Also, changing the background and changing it back to the same one returns the pixels too. It's somehow attached to that specific photo. Plus, Ubuntu is using my Intel graphics card by default, so I don't know if NVIDIA is the problem.

Temporary solution: I changed the desktop environment to Ubuntu on Wayland (you could do that from the login screen using the little tiny settings button if you reading this are also a noob like me :D) and it's fixed for now. I saw some stuff on the Internet that it uses more power, but for now I'll stick with it until I find a solution for the default DE. Will post if I find anything.

  • Do you have graphic card? – PRATAP May 1 at 7:37
  • Change the driver for the graphics card. See "additonal drivers" – Rinzwind May 1 at 7:41
  • I changed it to NVIDIA's driver (proprietary, tested) and it got worse :)) There are now other random pixels AND they appear on login screen too. – Amirali May 1 at 7:58
  • I had similar weird glitches like that with AMD gpu too on XFCE desktop but when I switched to other DE it all disappeared and works fine since then. Maybe there's some DE incompatibilities. – JoKeR May 1 at 8:41
  • 1
    Yes it does. I already answered this question with the same solution too, but thank you for your time ^-^ – Amirali May 29 at 7:07
5

Removing the xserver-xorg-video-intel package via

sudo apt remove xserver-xorg-video-intel

worked for me.

Source: Comment #16 on this bug.

| improve this answer | |
  • 1
    I was experiencing this issue on a Dell XPS 15 9550 with ubuntu 20.04 LTS. The visual artifacts were roughly the same size and orientation. Removing xserver-xorg-video-intel fixed the issue for me as well. – converter42 May 16 at 17:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.